<!DOCTYPE html>
<html lang="en" xmlns:og="http://ogp.me/ns#">
<head>
    <meta charset="utf-8">
    <meta name="viewport" content="width=device-width; initial-scale=1.0">
    <title>The big, big 2021 All About sites accessory review update</title>
    <link rel="image_src" href="http://allaboutwindowsphone.com/images/icons/1_gadgets2020.jpg"/>
    <link rel="canonical" href="http://www.allaboutsymbian.com/features/item/24302_TheAccessoriesTaleWhateverHapp.php"/>
    <link rel="stylesheet" href="http://www.allaboutsymbian.com/css/style.css">
    <link rel="stylesheet" type="text/css" href="http://www.allaboutsymbian.com/backend/highslide/highslide.css" />
    <link rel="alternate" type="application/rss+xml" title="All About Symbian RSS Feed" href="http://rss.allaboutsymbian.com/news/aas-feed-summary-all.xml" />
    <link href="https://plus.google.com/116524331534265995610" rel="publisher" />
        <script src="http://www.allaboutwindowsphone.com/js/libs/modernizr.custom.js"></script>
    <script src="http://www.allaboutwindowsphone.com/js/libs/mediaqueries.js"></script>
    <script type='text/javascript'>
    var googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
    (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
    '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
    })();
    </script>

    <script type='text/javascript'>
    googletag.cmd.push(function() {
    googletag.defineSlot('/1003985/AAN_Content_Rectangle', [336, 280], 'div-gpt-ad-1329661169970-0').addService(googletag.pubads());
    googletag.defineSlot('/1003985/AAS_Content_Side_Skyscraper', [160, 600], 'div-gpt-ad-1329661169970-1').addService(googletag.pubads());
    googletag.defineSlot('/1003985/AAS_Content_Top_Leaderboard', [728, 90], 'div-gpt-ad-1329661169970-2').addService(googletag.pubads());
    googletag.defineSlot('/1003985/AAS-Half-Page', [300, 600], 'div-gpt-ad-1378385703609-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
    });
    </script>
    <meta property="og:title" content="The big, big 2021 All About sites accessory review update"/>
    <meta property="og:description" content="Over the last three years on the All About sites, I've reviewed dozens of useful smartphone accessories. Most of which I still own. But, as I've bemoaned before, accessories have a habit of ceasing to be available, frustrating those who follow slightly older review links and hit a brick wall. Begging the question - what's still available and how has it held up in week-on-week use? Here's everything you need - and links which all work (where possible)!"/>
    <meta property="og:type" content="article"/>
    <meta property="og:url" content="http://www.allaboutsymbian.com/features/item/24302_TheAccessoriesTaleWhateverHapp.php"/>
    <meta property="og:image" content="http://allaboutwindowsphone.com/images/icons/1_gadgets2020.jpg"/>
    <meta property="og:site_name" content="All About Symbian"/>
    <meta property="fb:page_id" content="60924791991" />

        <style>
.containerimg {width:900px; margin:0 auto;}
.pic1 {width:900px; height:506px;}
.ba-mask {position:absolute; top:0; left:0; z-index:100; border-right:3px solid #333; overflow:hidden; box-shadow: 3px 5px 5px rgba(0, 0, 0, 0.6);box-shadow: 5px 5px 10px rgba(0, 0, 0, 0.6); -webkit-box-shadow: 5px 5px 7px rgba(0, 0, 0, 0.6);  -moz-box-shadow: 5px 0 7px rgba(0, 0, 0, 0.6);}
.ba-bg {position:absolute; top:0; left:0; z-index:0;}
.ba-caption {position:absolute; bottom:10px; left:10px; z-index:120; background:#000; filter:alpha(opacity=80);-moz-opacity:0.8;-khtml-opacity: 0.8;opacity: 0.8; color:#fff; text-align:center;-webkit-border-radius:5px; -moz-border-radius:5px; border-radius:5px; padding:5px; font-size:12px; font-family:arial; display:none;}
        </style>
</head>
<body>
<!-- BuySellAds Ad Code -->
<script type="text/javascript">
(function(){
  var bsa = document.createElement('script');
     bsa.type = 'text/javascript';
     bsa.async = true;
     bsa.src = 'http://s3.buysellads.com/ac/bsa.js';
  (document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(bsa);
})();
</script>
<!-- End BuySellAds Ad Code -->
<div id="container">

<header role="banner" class="one tborder">
  <hgroup id="branding">
      <h1 id="site-title"><a href="http://www.allaboutsymbian.com" rel="index" title="Go to home page">All About Symbian</a></h1>
      <h2 id="tag">News, reviews, information and apps for Symbian and Nokia.</h2>
  </hgroup>
  <div class="logo"><a href="http://www.allaboutsymbian.com"><img id="sitelogo" src="http://www.allaboutsymbian.com/images/site/logo.png"></a></div>
  <div class="topa">          <div id='div-gpt-ad-1329661169970-2' style='width:728px; height:90px;'>
          <script type='text/javascript'>
          googletag.cmd.push(function() { googletag.display('div-gpt-ad-1329661169970-2'); });
          </script>
          </div></div></header>

<nav role="navigation" class="one" id="navbar">
  <ul>
      <li><a href="http://www.allaboutsymbian.com/" title="Home page" >Home</a></li>
      <li><a href="http://www.allaboutsymbian.com/flow/" title="A curated stream of information on Symbian">Flow</a></li>
      <li><a href="http://www.allaboutsymbian.com/news/" title="Editorial news">News</a></li>
      <li><a href="http://www.allaboutsymbian.com/reviews/" title="Phone, accesory, app and games reviews">Reviews</a></li>
      <li class="navcurrent"><a href="http://www.allaboutsymbian.com/features/" title="In depth analysis, tutorials and guides">Features</a></li>
      <li><a href="http://www.allaboutsymbian.com/media/" title="Podcast and videos">Media</a></li>
      <li><a href="http://www.allaboutsymbian.com/software/" title="Software (app and game) directory">Apps &amp; Games</a></li>
      <li><a href="http://www.allaboutsymbian.com/forum/" title="Discussion Forum">Forum</a></li>
  </ul>
</nav>



<article role="main" class="maincolumn3" itemscope itemtype="http://schema.org/Article">
<div class="sprbr spleft spright3 content" id="maincontent">
  <h1 class="bborder" itemprop="name">The big, big 2021 All About sites accessory review update</h1>
  <p>Published by <span itemprop="author"><a itemprop="author" rel="author" href="http://www.allaboutsymbian.com/authors/steve-litchfield.php">Steve Litchfield</a></span> at <time itemprop="datePublished" datetime="2021-08-02T09:46:00+00:00">9:46 UTC, August 2nd 2021</time></p>
  <div itemprop="description">
  <p>Over the last three years on the All About sites, I've reviewed dozens of useful smartphone accessories. Most of which I still own. But, as I've bemoaned before, accessories have a habit of ceasing to be available, frustrating those who follow slightly older review links and hit a brick wall. Begging the question - what's still available and how has it held up in week-on-week use? Here's everything you need - and links which all work (where possible)!</p>  </div>
                      <div class="itemstrip">
                    <script type="text/javascript"><!--
                      google_ad_client = "pub-8131361875587051";
                      google_ad_width = 728;
                      google_ad_height = 15;
                      google_ad_format = "728x15_0ads_al";
                      google_ad_channel ="1730182810";
                      google_color_border = "FFFFFF";
                      google_color_bg = "FFFFFF";
                      google_color_link = "003366";
                      google_color_url = "003366";
                      google_color_text = "000000";
                      //--></script>
                      <script type="text/javascript"
                        src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
                      </script></div>  <div itemprop="articleBody">
  <p style="text-align: center;"><img class="photoborder" src="http://allaboutwindowsphone.com/images/features/misc/gadgets2020.jpg" alt="Gadget bag" /></p>
<p style="text-align: center;">(Image from my <a href="https://allaboutmobile.com/features/item/23894_Three_years_on_Whats_in_Steves.php" target="_blank">most recent gadget bag write-up</a>, and which is already significantly out of date!)</p>
<p>You'll, of course, have your own favourite accessories, but here goes with the items I've reviewed since 2015 and their current status!</p>
<p>NB: in numerous cases, brands (Choetech, Tronsmart, TaoTronics, RavPower, dodoCool, and others) have been hit with bans from Amazon because of various 'dodgy' practices, sadly, so I've tried to link to their manufacturer's home/product page. I should note that <strong><em>at no stage have we been part of a 'dodgy' review</em></strong>, but I do recognise that vouchers in boxes and 'free for five star reviews on Amazon', and so on, have been employed for some products and I understand Amazon's stance. It's just a shame in most cases, since these are decent products that have been made harder to get because of over-zealous Asian marketeers. 8-( So, rather than buying from our local Amazon, we now have to order from the other side of the planet and wait weeks. Gah.</p>
<p>NB2: where I state that I gave something away, I'm usually referring to the weekly giveaways from my <a href="https://stevelitchfield.com/sshow/chat.html" target="_blank">Phones Show Chat podcast</a>(!)</p>
<table border="1" cellpadding="6">
<tbody>
<tr>
<td><strong>Accessory</strong></td>
<td><strong>Reviewed in</strong></td>
<td><strong>Still in use?</strong></td>
<td><strong>Still for sale?</strong></td>
</tr>
<tr>
<td><a href="http://allaboutwindowsphone.com/reviews/item/22996_Dodocool_DP13_45W_Type-C_Fast_.php" target="_blank">dodocool DP13 45W Type C PD</a><a href="http://allaboutwindowsphone.com/reviews/item/23229_ZAGG_Flex_Universal_Keyboard.php" target="_blank"></a></td>
<td>2018</td>
<td>Yes, always in my briefcase to this day. Sleek, metal, powerful.</td>
<td>Sadly no</td>
</tr>
<tr>
<td><a href="http://allaboutwindowsphone.com/reviews/item/23229_ZAGG_Flex_Universal_Keyboard.php" target="_blank">ZAGG Flex Universal keyboard</a></td>
<td>2018</td>
<td>Yes, still my favourite Bluetooth keyboard EVER.</td>
<td>Yes, via <a href="https://www.zagg.com/en_uk/flex?utm_source=CJ&amp;utm_medium=Affiliates&amp;cjevent=834368c1f38111eb80e001050a18050c" target="_blank">ZAGG</a></td>
</tr>
<tr>
<td><a href="http://allaboutwindowsphone.com/reviews/item/23430_Monoprice_Triple_XXX_Driver_Ea.php" target="_blank">Monoprice Triple XXX Driver Earbuds</a><br /></td>
<td>2019</td>
<td>Still my favourite budget wired in-ears. When my ears can take them!</td>
<td>Sadly no</td>
</tr>
<tr>
<td><a href="http://allaboutwindowsphone.com/reviews/item/23456_Powstro_USB_Windows_Hello_Fing.php" target="_blank">Powstro USB 'Windows Hello' Multi Fingerprint Reader</a><br /></td>
<td>2019&nbsp;</td>
<td>Yes, plugged into the USB port of my original Surface Pro.</td>
<td>Yes, from <a href="https://amzn.to/3A2FuUK" target="_blank">Amazon</a></td>
</tr>
<tr>
<td><a href="http://allaboutwindowsphone.com/reviews/item/23460_HIDIZS_Portable_Headphone_Ampl.php" target="_blank">HIDIZS Sonata HD Mk II</a>&nbsp;<br /></td>
<td>2019</td>
<td>Yes, whenever I need audio from any Type C-only smartphone (e.g. Samsung)</td>
<td>Sadly no, though see <a href="http://allaboutwindowsphone.com/features/item/23960_Smartphone_wired_audio_and_DAC.php" target="_blank">other options here</a></td>
</tr>
<tr>
<td><a href="http://allaboutwindowsphone.com/reviews/item/23473_T5.php" target="_blank">T5 Ultra Connect Bluetooth heaphones</a><br /></td>
<td>2019</td>
<td>Yes, though my ears have been getting a little sore from in-canal use, so I've switched mostly to on-ear Marshalls (see below).</td>
<td>Yes, from <a href="https://amzn.to/2V5QulL" target="_blank">Amazon</a></td>
</tr>
<tr>
<td><a href="http://allaboutwindowsphone.com/reviews/item/23487_Tribit_MaxSound_Plus.php" target="_blank">Tribit MaxSound Plus 24W</a><br /></td>
<td>2019</td>
<td>Since superceded by even better speakers, but it's still terrific and, crucially, not affected by Amazon's brand ban...</td>
<td>Yes, from <a href="https://amzn.to/3xkuVeb" target="_blank">Amazon</a></td>
</tr>
<tr>
<td><a href="http://allaboutwindowsphone.com/reviews/item/23525_Choetech_10W_Fast_Wireless_Car.php" target="_blank">Choetech T521/S - 10W Fast Wireless Car Charger Mount</a><br /></td>
<td>2019</td>
<td>Daily, it's in my car right now, wirelessly charging everything that's clamped inside it.</td>
<td>Yes, from <a href="https://choetech.com/collections/wireless-car-charger/products/choetech-qi-wireless-charger-for-samsung-galaxy-s8-plus-10w-wireless-charger-car-dock-s7-s6-fast-wireless-charging-phone-stand?variant=12779915411511" target="_blank">Choetech</a></td>
</tr>
<tr>
<td><a href="http://allaboutwindowsphone.com/reviews/item/23540_Choetech_19W_SC001_Solar_Charg.php" target="_blank">Choetech SC001 19W Solar Charger</a><br /></td>
<td>2019</td>
<td>Occasionally, see my <a href="https://allaboutmobile.com/features/item/24261_Whysolarpowerbankscanneverwork.php" target="_blank">solar charging feature</a>.</td>
<td>Yes, from <a href="https://choetech.com/collections/solar-charger/products/solar-charger-19w-solar-phone-charger-with-dual-usb-ports?variant=12779927666743" target="_blank">Choetech</a></td>
</tr>
<tr>
<td><a href="http://allaboutwindowsphone.com/reviews/item/23543_Tronsmart_PB20_Personal_Percen.php" target="_blank">Tronsmart PB20</a><br /></td>
<td>2019</td>
<td>In my power bank rotation, still very solid.</td>
<td>Yes, from <a href="https://www.geekbuying.com/item/Tronsmart-PB20-Power-Bank-417072.html?idev_id=864" target="_blank">GeekBuying</a></td>
</tr>
<tr>
<td><a href="http://allaboutwindowsphone.com/reviews/item/23557_Tronsmart_Element_T6_Plus.php" target="_blank">Tronsmart Element T6 Plus&nbsp;</a></td>
<td>2019</td>
<td>Daily, super sound for modest bulk.</td>
<td>Yes, from <a href="https://amzn.to/3xjJkaz" target="_blank">Amazon</a></td>
</tr>
<tr>
<td><a href="http://allaboutwindowsphone.com/reviews/item/23665_TaoTronics_True_Wireless_Sound.php" target="_blank">TaoTronics 'True Wireless' SoundLiberty 53 Earbuds</a><br /></td>
<td>2019</td>
<td>No, I've never really got on with any TWS earbuds. Sorry. Might be me. Gave them away.<br /></td>
<td>Yes, from <a href="https://www.taotronics.com/products/upgraded-tt-bh053-wireless-earbuds" target="_blank">TaoTronics</a>&nbsp;</td>
</tr>
<tr>
<td><a href="https://allaboutmobile.com/reviews/item/23639_Choetech_T555-F_Fast_Wireless_.php" target="_blank">Choetech T555-F Fast Wireless Charging Stand</a><br /></td>
<td>2019</td>
<td>Yes, by a friend. I gave it away to someone in need!</td>
<td>Yes, from <a href="https://choetech.com/collections/wireless-charger-stand/products/choetech-7-5w-fast-charger-stand-for-iphone-multi-colors?variant=12898867904567" target="_blank">Choetech</a></td>
</tr>
<tr>
<td><a href="https://allaboutmobile.com/reviews/item/23713_Tranya_Rimor_True_Wireless_Ear.php" target="_blank">Tranya Rimor True Wireless Earbuds</a><br /></td>
<td>2019</td>
<td>No, I've never really got on with any TWS earbuds. Sorry. Might be me.&nbsp;Gave them away.<br /></td>
<td>Sadly no</td>
</tr>
<tr>
<td><a href="https://allaboutmobile.com/reviews/item/23854_ROMOSS_26800mAh_18W_PD_Quick_C.php" target="_blank">ROMOSS 'Sense 8+' 26800(+)mAh, 18W power bank</a><br /></td>
<td>2020</td>
<td>Part of my&nbsp;<a href="https://stevelitchfield.com/sshow/ss421.html" target="_blank">'car kit'</a>, a system of 12V to power bank 'cache' to smartphones and Surface hybrid. (photo below)<br /></td>
<td>Yes, from <a href="https://amzn.to/37tGRQp" target="_blank">Amazon</a></td>
</tr>
<tr>
<td colspan="4"><a href="https://allaboutmobile.com/reviews/item/23854_ROMOSS_26800mAh_18W_PD_Quick_C.php" target="_blank"><img src="http://allaboutwindowsphone.com/images/features/misc/romoss4.jpg" alt="ROMOSS power bank" /></a></td>
</tr>
<tr>
<td><a href="https://allaboutmobile.com/reviews/item/23888_RAVPower_PD_Pioneer_20000_AC.php" target="_blank">RAVPower PD Pioneer 20000 AC</a><br /></td>
<td>2020</td>
<td>Part of my <a href="https://stevelitchfield.com/sshow/ss421.html" target="_blank">'car kit'</a>, a system of 12V to power bank to (as a last resort) mains, if needed!</td>
<td>Sadly no</td>
</tr>
<tr>
<td><a href="https://allaboutmobile.com/reviews/item/23941_Realme_Buds_Q.php" target="_blank">Realme Buds Q&nbsp;</a></td>
<td>2020</td>
<td>No, I've never really got on with any TWS earbuds. Sorry. Might be me.&nbsp;Gave them away.</td>
<td>Yes, from <a href="https://amzn.to/3lhR62d" target="_blank">Amazon</a></td>
</tr>
<tr>
<td><a href="https://allaboutmobile.com/reviews/item/23951_Tribit_QuietPlus_72_Type_C-cha.php" target="_blank">Tribit QuietPlus 72 Type C-charging ANC headphones</a><br /></td>
<td>2020</td>
<td>No, these got usurped by my favourite Marshalls. But still a decent option.&nbsp;Gave them away.</td>
<td>Yes, from <a href="https://amzn.to/37c8FbR" target="_blank">Amazon</a></td>
</tr>
<tr>
<td><a href="https://allaboutmobile.com/reviews/item/23954_Vava_12-in-1_USB_Type_C_Dockin.php" target="_blank">Vava 12-in-1 USB Type C Docking Station</a><br /></td>
<td>2020</td>
<td>Fortnightly, I have this set up for my Surface Go as a 'hot desk' system at my dad's house<br /></td>
<td>Sadly no, but there are plenty of <a href="https://amzn.to/3xlChOt" target="_blank">similar docks on Amazon</a>&nbsp;</td>
</tr>
<tr>
<td><a href="https://allaboutmobile.com/reviews/item/24011_Mini-review_RAVPower_65W_PD_Pi.php" target="_blank">RAVPower 65W PD 'Pioneer' 4-port desktop charger</a><br /></td>
<td>2020</td>
<td>Fortnightly, I have this plugged in as part of a charging 'dock' system at my dad's house</td>
<td>Yes, though rebranded, on <a href="https://amzn.to/2WKkWSO" target="_blank">Amazon</a></td>
</tr>
<tr>
<td><a href="https://allaboutmobile.com/reviews/item/23735_PONSINC_Wireless_10000mAh_char.php" target="_blank">Aenkyo (/PONSINC) 'Air Wireless' 10000mAh power bank</a><br /></td>
<td>2020</td>
<td>Daily, one of the most useful charging gadgets I own, I have two!</td>
<td>Sadly no</td>
</tr>
<tr>
<td><a href="https://allaboutmobile.com/reviews/item/24059_TypeCincludingPowerDeliveryrou.php" target="_blank">Olixar 18W USB Type C adapter</a></td>
<td>2020&nbsp;</td>
<td>In use around the house</td>
<td>Yes, from <a href="https://www.mobilefun.co.uk/olixar-power-delivery-18w-single-usb-c-wall-charger-uk-plug-black-79666" target="_blank">MobileFun</a></td>
</tr>
<tr>
<td><a href="https://allaboutmobile.com/reviews/item/24059_TypeCincludingPowerDeliveryrou.php" target="_blank">Apple 20W USB Type C folding adapter</a></td>
<td>2020</td>
<td>Daily, and when travelling</td>
<td>Yes, from <a href="https://www.apple.com/uk/shop/product/MHJF3B/A/20w-usb-c-power-adapter" target="_blank">Apple</a></td>
</tr>
<tr>
<td><a href="https://allaboutmobile.com/reviews/item/24063_NexDockTouch.php" target="_blank">NexDock Touch</a><br /></td>
<td>2020</td>
<td>As needed, still a really interesting mobile work option.</td>
<td><a href="http://allaboutwindowsphone.com/news/item/24088_TheNexDockTouchisdeadLonglivet.php" target="_blank">No, due to component sourcing issues</a></td>
</tr>
<tr>
<td><a href="https://allaboutmobile.com/reviews/item/24065_Choetech10000mAh2-in-1Wireless.php" target="_blank">Choetech 10000mAh 2-in-1 Wireless Charger</a><br /></td>
<td>2020</td>
<td>Weekly, as needed. I particularly like the Qi charging through the top surface</td>
<td>Yes,&nbsp;from <a href="https://choetech.com/collections/power-bank-station/products/power-bank-phone-charger-portable-qi-wireless-battery-charger?variant=37878348808381" target="_blank">Choetech</a></td>
</tr>
<tr>
<td><a href="https://allaboutmobile.com/reviews/item/24073_TronsmartMegaPro60W10000mAhBlu.php" target="_blank">Tronsmart Mega Pro 60W 10000mAh Bluetooth</a><br /></td>
<td>2020</td>
<td>Always in my current 'large' gadget bag, which goes with me on trips. (photo below)</td>
<td>Yes,&nbsp;from <a href="https://amzn.to/39KpE7B" target="_blank">Amazon</a></td>
</tr>
<tr>
<td><a href="https://allaboutmobile.com/reviews/item/24121_GastonLugaPraperlaptopbackpack.php" target="_blank">Gaston Luga Praper laptop backpack</a><br /></td>
<td>2021</td>
<td>Not used currently, awaiting a gadget bag overhaul!</td>
<td>Yes,&nbsp;from <a href="https://gastonluga.com/" target="_blank">Gaston Luga</a></td>
</tr>
<tr>
<td><a href="https://allaboutmobile.com/reviews/item/24219_MarshallMajorIVBluetooth.php" target="_blank">Marshall Major IV Bluetooth</a></td>
<td>2021</td>
<td>Daily, best audio product I ever owned</td>
<td>Yes,&nbsp;from <a href="https://amzn.to/3ezJRiv" target="_blank">Amazon</a></td>
</tr>
<tr>
<td><a href="https://allaboutmobile.com/reviews/item/24243_MoshiSetteQtwinhighpowerQichar.php" target="_blank">Moshi Sette Q 'twin 15W' Qi charger</a><br /></td>
<td>2021</td>
<td>Daily, on my desk!</td>
<td>Yes,&nbsp;from <a href="https://moshi.com/en/product/sette-q-dual-wireless-charging-pad/nordic-gray/" target="_blank">Moshi</a></td>
</tr>
<tr>
<td><a href="https://allaboutmobile.com/reviews/item/24278_Tegic4-in-1TypeCLightningUSB-A.php" target="_blank">Tegic 4-in-1 Type C/Lightning/USB-A multi-cable</a><br /></td>
<td>2021</td>
<td>Daily, on various phones/gadgets</td>
<td>Yes,&nbsp;from <a href="https://www.tegic.design/product-page/onix" target="_blank">Tegic</a></td>
</tr>
<tr>
<td><a href="https://allaboutmobile.com/reviews/item/24279_TegicBLOCK30CNC-machinedpowerb.php" target="_blank">Tegic 'BLOCK 30' power bank</a><br /></td>
<td>2021</td>
<td>Weekly, as needed</td>
<td>Yes, from&nbsp;<a href="https://www.tegic.design/product-page/block-30-grey" target="_blank">Tegic</a></td>
</tr>
<tr>
<td><a href="https://allaboutmobile.com/reviews/item/24295_Soaraise.php" target="_blank">Soaraise flying lead power bank</a></td>
<td>2021</td>
<td>Daily, so convenient never having to look for leads(!)</td>
<td>Yes,&nbsp;from <a href="https://amzn.to/3zAUnh4" target="_blank">Amazon</a></td>
</tr>
</tbody>
</table>
<p>It's a shame that Amazon's latest updates have split apart the links in the original reviews, but hopefully my recommended links above will help you track something down after you've read my review text in each case.</p>
<p style="text-align: center;"><img class="photoborder" src="http://allaboutwindowsphone.com/images/features/misc/megapro7.jpg" alt="Tronsmart MegaPro" /><br /></p>
<p>As ever, comments welcome - do you have a couple of favourite accessories that you couldn't do without? And, yes, I'll be updating my own 'gadget bag' feature soon as part of a summer holiday 'spring clean' (ahem)...</p>  </div>

  <aside role="contentinfo" class="btop">
                        <div style="float:right;margin:2px 5px;">
                    <div id='div-gpt-ad-1329661169970-0' style='width:336px; height:280px;'>
                    <script type='text/javascript'>
                    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1329661169970-0'); });
                    </script>
                    </div>
                    </div>
    <h2>Meta, Share, Comments</h2>
     <p itemscope itemtype="http://data-vocabulary.org/Breadcrumb">Filed:
     <span><a itemprop="url" href="http://www.allaboutsymbian.com"><span itemprop="title">Home</span></a></span> > <span itemprop="child" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="http://www.allaboutsymbian.com/features/"><span itemprop="title">Features</span></a> > <span  itemprop="child" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="http://www.allaboutsymbian.com/features/item/24302_TheAccessoriesTaleWhateverHapp.php"><span itemprop="title">The big, big 2021 All About sites accessory review update</span></a></span></span>
    </p>
    <p>Platforms: <a href="http://www.allaboutsymbian.com/features/General/">General</a>, <a href="http://www.allaboutsymbian.com/features/General/">General</a>, <a href="http://www.allaboutsymbian.com/features/General/">General</a>    <br />Categories: <a itemprop="articleSection" href="http://www.allaboutsymbian.com/features/all/Comment/">Comment</a>, <a itemprop="articleSection" href="http://www.allaboutsymbian.com/features/all/Hardware/">Hardware</a><br />&nbsp;
    <meta itemprop="image" content="http://allaboutwindowsphone.com/images/icons/1_gadgets2020.jpg" />
    <meta itemprop="url" content="http://www.allaboutsymbian.com/features/item/24302_TheAccessoriesTaleWhateverHapp.php" /></p>
    <p>
    <!-- AddThis Button BEGIN -->
    <div class="addthis_toolbox addthis_default_style addthis_32x32_style">
    <a class="addthis_button_google_plusone" g:plusone:annotation="bubble"></a><a class="addthis_button_facebook_like" fb:like:layout="standard"></a><br /><br />
    <a class="addthis_button_preferred_1"></a>
    <a class="addthis_button_preferred_2"></a>
    <a class="addthis_button_preferred_3"></a>
    <a class="addthis_button_preferred_4"></a>
    <a class="addthis_button_preferred_5"></a>
    <a class="addthis_button_compact"></a>
    <a class="addthis_counter addthis_bubble_style"></a>
    </div>
    <script type="text/javascript" src="http://s7.addthis.com/js/250/addthis_widget.js#pubid=ra-4e8dc6a04a3c4e74"></script>
    <!-- AddThis Button END -->
    </p>

    <div id="disqus_thread" class="btop"></div>
    <script type="text/javascript">
        /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
        var disqus_shortname = 'aas'; // required: replace example with your forum shortname
        var disqus_identifier = 24302;
        var disqus_title = 'The big, big 2021 All About sites accessory review update';
        /* * * DON'T EDIT BELOW THIS LINE * * */
        (function() {
            var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
            dsq.src = 'http://' + disqus_shortname + '.disqus.com/embed.js';
            (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
        })();
    </script>
    <noscript>Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>


    </aside>
    </div>
</article>

<aside role="complementary" class="sidebar3">
  <div class="spl spright spleft3" id="sidec">
        <h3 class="ctitle bborder">Search</h3>
<form class="sform cen" action="http://www.google.com/cse" id="cse-search-box">
  <div>
    <input type="hidden" name="cx" value="017164901485882693956:egeufrhadzc" />
    <input type="hidden" name="ie" value="UTF-8" />
    <input class="sinput" type="text" name="q" size="17" />
    <input class="sbutt" type="submit" name="sa" value="Go" />
  </div>
</form>
<script type="text/javascript" src="//www.google.com/cse/brand?form=cse-search-box&lang=en"></script>
      <h3 class="ctitle bborder">Adverts</h3>
<div style="width:310px;text-align:center;margin:0 auto;">
<div style="text-align:center;">
<!-- BuySellAds Zone Code -->
<div id="bsap_1290278" class="bsarocks bsap_46dc95c18c9576d32c2b305f41f2e43a"></div>
<!-- End BuySellAds Zone Code -->
</div>
</div>
<div style="clear:both;"></div>

        <h3 class="ctitle bborder">Social</h3>
    <p class="sociali"><a href="http://rss.allaboutsymbian.com/news/aas-feed-summary-all.xml"><img src="http://www.allaboutsymbian.com/images/site/rss-32x32.png" /></a><a href="http://rss.allaboutsymbian.com/news/aas-feed-summary-all.xml">Subscribe by RSS</a></p>
    <p class="sociali"><a href="http://twitter.com/#!/aas"><img src="http://www.allaboutsymbian.com/images/site/twitter-32x32.png" /></a><a href="http://twitter.com/#!/aas">Follow on Twitter</a></p>
    <p class="sociali"><a href="https://plus.google.com/116524331534265995610"><img src="http://allaboutsymbian.com/images/site/googlep-32x32.png" /></a><a href="https://plus.google.com/116524331534265995610">Find us on Google+</a></p>
    <p class="sociali"><a href="http://www.facebook.com/allaboutsymbian"><img src="http://allaboutsymbian.com/images/site/facebook-32x32.png" /></a><a href="http://www.facebook.com/allaboutsymbian">Like on Facebook</a></p>
    <p class="sociali"><a href="http://allaboutsymbian.com/community.php"><img src="http://allaboutsymbian.com/images/site/heart-32x32.png" /></a><a href="http://www.allaboutsymbian.com/community.php">Top Comments</a></p>


    
      <h3 class="ctitle bborder">Accessibility</h3>
    <p>Font Size: &nbsp; &nbsp; <a href="#" title="Decrease Font Size" class="decreaseFont">A-</a>
    <a href="#" title="Reset Font Size" class="resetFont">A</a>
    <a href="#" title="Increase Font Size"  class="increaseFont">A+</a></p>
  
    <div id="google_translate_element">Translate: </div>
    <script>
        function googleTranslateElementInit() {
          new google.translate.TranslateElement({
            pageLanguage: 'en',
            gaTrack: true,
            gaId: 'UA-25950422-1'
          }, 'google_translate_element');
        }
    </script>
    <script src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script>
    


  <h3 class="ctitle bborder">Highlighted Features</h3>
            <article class="fea-art">
<figure><a href="http://www.allaboutsymbian.com/features/item/24202_DSLRvscameraphone2021-arewethe.php"><img alt="featured icon" src="http://allaboutwindowsphone.com/images/icons/1_iphone-dslr.jpg" /></a></figure>
<h2 class="fea-caption"><a href="http://www.allaboutsymbian.com/features/item/24202_DSLRvscameraphone2021-arewethe.php">DSLR vs camera phone, 2021 - are we there, yet?</a></h2>
</article><article class="fea-art">
<figure><a href="http://www.allaboutsymbian.com/features/item/24170_2021Smartphonephotostoragethou.php"><img alt="featured icon" src="http://allaboutwindowsphone.com/images/icons/Screenshot%202021-03-24%20at%2011.37.34.png" /></a></figure>
<h2 class="fea-caption"><a href="http://www.allaboutsymbian.com/features/item/24170_2021Smartphonephotostoragethou.php">2021 Smartphone photo storage thoughts</a></h2>
</article><article class="fea-art">
<figure><a href="http://www.allaboutsymbian.com/features/item/24153_Youwantedityougotit2021PureVie.php"><img alt="featured icon" src="http://allaboutwindowsphone.com/images/icons/1_4way-pure.jpg" /></a></figure>
<h2 class="fea-caption"><a href="http://www.allaboutsymbian.com/features/item/24153_Youwantedityougotit2021PureVie.php">A 2021 &#39;PureView&#39; battle: 808/1020/Pixel/iPhone</a></h2>
</article><article class="fea-art">
<figure><a href="http://www.allaboutsymbian.com/features/item/23925_Steves_Top_10_tips_for_taking_.php"><img alt="featured icon" src="http://allaboutwindowsphone.com/images/icons/photos-cameras.jpg" /></a></figure>
<h2 class="fea-caption"><a href="http://www.allaboutsymbian.com/features/item/23925_Steves_Top_10_tips_for_taking_.php">Top 10 tips for taking better photos on your phone</a></h2>
</article><article class="fea-art">
<figure><a href="http://www.allaboutsymbian.com/features/item/23911_Camera_head_to_head_Lumia_950_.php"><img alt="featured icon" src="http://allaboutwindowsphone.com/images/icons/1_6way.jpg" /></a></figure>
<h2 class="fea-caption"><a href="http://www.allaboutsymbian.com/features/item/23911_Camera_head_to_head_Lumia_950_.php">A six way imaging head to head: Realme X3 SuperZoom vs Nokia 808/1020, etc.</a></h2>
</article><article class="fea-art">
<figure><a href="http://www.allaboutsymbian.com/features/item/23700_By_popular_request_really_2012.php"><img alt="featured icon" src="http://allaboutwindowsphone.com/images/icons/IMG_20191125_141430.jpg" /></a></figure>
<h2 class="fea-caption"><a href="http://www.allaboutsymbian.com/features/item/23700_By_popular_request_really_2012.php">By popular request (really): 2012&#039;s Nokia 808 PureView vs the best of 2019</a></h2>
</article><article class="fea-art">
<figure><a href="http://www.allaboutsymbian.com/features/item/23556_Real_world_phone_imaging_zoom_.php"><img alt="featured icon" src="http://allaboutwindowsphone.com/images/icons/bladex1-scene.jpg" /></a></figure>
<h2 class="fea-caption"><a href="http://www.allaboutsymbian.com/features/item/23556_Real_world_phone_imaging_zoom_.php">Real world (2x, 3x) phone imaging zoom tests: a variety of approaches!</a></h2>
</article><article class="fea-art">
<figure><a href="http://www.allaboutsymbian.com/features/item/23435_Imaging_showdown_Nokia_808_Sym.php"><img alt="featured icon" src="http://allaboutwindowsphone.com/images/icons/1_pureview-four.jpg" /></a></figure>
<h2 class="fea-caption"><a href="http://www.allaboutsymbian.com/features/item/23435_Imaging_showdown_Nokia_808_Sym.php">PureView showdown: Nokia 808 (Symbian), 1020 (WP8.1), 950 (W10M), 9 (Android)</a></h2>
</article>          <h3 class="ctitle bborder">Adverts</h3>
<div class="sideas">
                <div id='div-gpt-ad-1329661169970-1' style='width:160px; height:600px;margin:auto;'>
                <script type='text/javascript'>
                googletag.cmd.push(function() { googletag.display('div-gpt-ad-1329661169970-1'); });
                </script>
                </div>
</div>

    </div>

</aside>


<footer role="complementary" class="one">
  <section>
  <div id="footerbar">Copyright (&#169;) All About Symbian 2000-2020</div>
	<div class="onet">
	<div class="sprbr spleft spright3">
		<h3>About us:</h3>
                <p>All About Symbian provides an independent source of news, reviews, apps and more to the Symbian and Nokia ecosystem.</a><p>
                <p><a href="http://www.allaboutsymbian.com/about.php">More about us</a>.</p>
                <p>Get in touch: <a href="http://www.allaboutsymbian.com/contact.php">Email</a>, <a href="http://twitter.com/aas">Twitter</a> or <a href="http://www.facebook.com/allaboutsymbian">Facebook</a>.</p>
                <p><a href="http://allaboutsymbian.com/privacy.php">Privacy Policy</a></p>
                <p>&nbsp;</p>
	</div>
	</div>

	<div class="twot">
	<div class="sprbr spl spleft3 spright3">
		<h3>Site Sections:</h3>
		<ul>
                  <li><a href="http://allaboutsymbian.com" >Home</a></li>
                  <li><a href="http://allaboutsymbian.com/flow/" title="A curated stream of information on Symbian">Flow</a></li>
                  <li><a href="http://allaboutsymbian.com/news/" title="Editorial news">News</a></li>
                  <li><a href="http://allaboutsymbian.com/reviews/" title="Phone, accesory, app and games reviews">Reviews</a></li>
                  <li><a href="http://allaboutsymbian.com/features/" title="In depth analysis, tutorials and guides">Features</a></li>
                  <li><a href="http://allaboutsymbian.com/media/" title="Podcast and videos">Media</a></li>
                  <li><a href="http://allaboutsymbian.com/software/" title="Software (app and game) directory">Apps &amp; Games</a><br />&nbsp;</li>
                </ul>
               <h3>Also All About</h3>
		<ul>
                  <li><a href="http://www.allaboutwindowsphone.com" >All About Windows Phone</a></li>
                  <li><a href="http://www.allaboutmeego.com">All About MeeGo</a></li>
                </ul>
		</div>
	</div>

	<div class="threet">
	<div class="spl spright spleft3">
	<h3>Site notes</h3>
         <p>This website is not in any way endorsed by Nokia. Symbian and all Symbian marks and logos are trademarks of Nokia. <br /><br /><a href="http://allaboutsymbian.com/copyright.php">Additional copyright notes</a></p>
	</div></div>


  <section>
</footer>

</div>
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.6.2/jquery.min.js"></script>
<script>window.jQuery || document.write('<script src="http://www.www.allaboutsymbian.com/js/libs/jquery-1.6.2.min.js"><\/script>')</script>
<script defer src="/min/f=js/plugins.js"></script>
<script type="text/javascript">
		$(window).load(function() {
		        $("#maincontent").css("min-height",$("#sidec").height()+'px');
                        sitefunctions.textresize();
		});
</script>
<script src="http://allaboutwindowsphone.com/js/jquery.qbeforeafter.js" type="text/javascript"></script>
<script type="text/javascript">
	$(window).load(function() {
        $('.pic1').qbeforeafter({defaultgap:150,caption: true, reveal: 0.5});
	});
</script>
<script>
  window._gaq = [['_setAccount','UA-90123-1'],['_trackPageview'],['_trackPageLoadTime']];
  Modernizr.load({
    load: ('https:' == location.protocol ? '//ssl' : '//www') + '.google-analytics.com/ga.js'
  });
</script>
<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>
<script type="text/javascript">
var _sf_async_config={uid:30474,domain:"allaboutsymbian.com"};
(function(){
  function loadChartbeat() {
    window._sf_endpt=(new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src',
       (("https:" == document.location.protocol) ? "https://a248.e.akamai.net/chartbeat.download.akamai.com/102508/" : "http://static.chartbeat.com/") +
       "js/chartbeat.js");
    document.body.appendChild(e);
  }
  var oldonload = window.onload;
  window.onload = (typeof window.onload != 'function') ?
     loadChartbeat : function() { oldonload(); loadChartbeat(); };
})();

</script>
<script type="text/javascript" src="http://s.skimresources.com/js/51391X1256713.skimlinks.js"></script><style type="text/css">
.iTt{
    FONT-FAMILY:       Verdana, Arial, Helvetica;
    FONT-SIZE:         11px;
    FONT-STYLE:        normal;
    FONT-WEIGHT:       normal;
    COLOR:             black;
    BACKGROUND-COLOR:  lightyellow;
    BORDER:            black 1px solid;
    PADDING:           2px;
}
</style>
<script type="text/javascript" src="http://allaboutsymbian.uk.intellitxt.com/intellitxt/front.asp?ipid=3395&kwpn=1&mk=50&fg=3C3A7E&sn=nav3,nav,topstrip,nav,footer,content3,sidebar,sidebar3"></script>
</body>
</html>
