All About Symbian - Nokia (S60) and Sony Ericsson (UIQ) smartphones unwrapped

  #31  
Old 02-07-2009, 03:07 PM
davwil davwil is offline
Registered User
 
Join Date: Jan 2008
Posts: 15
davwil is on a distinguished road
Hi John

Make sure the nokia firmware are in C:\Program Files\Nokia\Phoenix\Products\RM-505

It took a few restart's of Jaf to to get it to recognise the new files.
Also pressing the power on button at the right button took a few goes.

Persistence is the key ;-)

Cheers David

  #32  
Old 02-07-2009, 03:21 PM
MrAaronVenn MrAaronVenn is offline
Registered User
 
Join Date: Jul 2009
Posts: 22
MrAaronVenn is on a distinguished road
Quote:
Originally Posted by Fats View Post
Holy crap this worked!!

Everyone that managed to brick their phone using JAF to debrand then NSU to update needs to check this out.

I used NAVIFIRM to download the v11 firmware set.
I had to fiddle with JAF because it didn't automatically pick up the correct ROMs, so I had to select them manually as follows:

MCU Flash file: C:\Temp\N97\firmware\RM-505_11.0.021_prd.core.C00
PPM Flash file: C:\Temp\N97\firmware\RM-505_11.0.021_prd.rofs2.V01
CNT Flash file: C:\Temp\N97\firmware\RM-505_11.0.021_C01_prd.rofs3.fpsx
APE Variant file: C:\Temp\N97\firmware\RM505_507_11.0.021_uda1_001.u da.fpsx

Select Maunal Flash, Dead USB, Factory Set and Normal mode and hit flash.

My N97 is now working again. I'm guessing it's on the right firmware because that's what I flashed, what's the *# code to check?

TYVM for the heads-up, andonevris.
Thank you so much mate for making this is so much easier & step by step.
I was trolling the forums for hours trying to find .ini files and all this crap...but anyways...

My ressurection goes fine until it gets to the "Pooling Phone" bit. The screen goes all LCD liney, then stops.
Then, JAF says something along the lines of:
"Did your phone turn back on, Yes No?"
when I click "No" cos it didn't back come back on, it just says "Done!" and finishes.
Though its not actually done, as the phone doesnt turn back on or do anything.

So I try it all again, but then click...YES
But when I click "Yes" JAF thinks for a while then says...
"Phone not found...
Second try...
MCUSW: (null)
APESW: (null)
VariantSW: (null)
Prodcode:
Setting test mode...
Failed! Aborting!
Done!"

It doesn't turn on or anything.
And JAF has finished.
All the while my laptop keeps making the "Ba-dum" noise of a USB being plugged in & out so it must have done something good?!

Does anyone have any ideas of what to do when it stops after Pooling?
Or tips as to why this might be happening?
Any help would be appreciated cos im sure if I take it to a Nokia Care Centre they'll whinge and chastise me....
Even if you email me its all good I don't mind i'd just like my phone to be working again after all this unpleasantness...

thanks again guys

Last edited by MrAaronVenn; 02-07-2009 at 03:29 PM.

  #33  
Old 02-07-2009, 04:24 PM
managerxxx managerxxx is offline
Registered User
 
Join Date: Jul 2009
Posts: 14
managerxxx is on a distinguished road
Quote:
Originally Posted by jmcgrath View Post
Folks,

I'm struggling here so please help.

When trying to locate the MCU file it is only letting me select CMT files. I can select the PPM, CNT and APE files without any problems.

I have also copied the jaf 1.98.64 ini files and I can see the N97 option but it does not seem to pick it up.

Any suggestions?

Thanks,

John
Yes I had the same issue - took me a couple of tries to discover if you simply type the path to the C00 file it'll accept it no problem.

Hope this helps

  #34  
Old 02-07-2009, 04:27 PM
jmcgrath jmcgrath is offline
Registered User
 
Join Date: May 2007
Location: Scotland
Posts: 69
jmcgrath is on a distinguished road
Woooooop Woooooop Wooooooop !!!!!

I managed to get my N97 working again.

A huge thank you to everyone, especially Fats and davwil. It was Dave's final comment of putting the FW files in a RM-505 folder that made the difference I think. I just had them sitting in the products folder. As soon as I did that JAF picked them up, everything was green and the re-flashing worked first time.

So thanks again everyone. I have to go now before the tears of joy short out me keyboard.

John

  #35  
Old 02-07-2009, 05:18 PM
nokion nokion is offline
Registered User
 
Join Date: Jul 2009
Posts: 4
nokion is on a distinguished road
Just wanted to say thanks to the guys that have posted in here. You've saved my bacon (and my phone). Now working again thankfully.

One thing I have noticed is that I no longer have a start up tone when I power on the phone. I think I missed out the media pack file when I flashed the handset Is it possible to just follow the procedure again but only select the media pack file to correct this?

  #36  
Old 02-07-2009, 05:34 PM
Mike.mp Mike.mp is offline
Registered User
 
Join Date: Jul 2009
Location: London
Posts: 38
Mike.mp is on a distinguished road
Nokion, you better just flash it again, but with NSU. Should be easy.

  #37  
Old 02-07-2009, 05:36 PM
nokion nokion is offline
Registered User
 
Join Date: Jul 2009
Posts: 4
nokion is on a distinguished road
Quote:
Originally Posted by Mike.mp View Post
Nokion, you better just flash it again, but with NSU. Should be easy.
After my previous encounter this afternoon I'm pretty wary of using NSU again. Perhaps I'll just go through the flashing process again.

  #38  
Old 02-07-2009, 05:41 PM
Mike.mp Mike.mp is offline
Registered User
 
Join Date: Jul 2009
Location: London
Posts: 38
Mike.mp is on a distinguished road
Its up to you, but it wont harm phone now Take easy way, and IF it won't work, you already know how to fix it.
Ads

  #39  
Old 02-07-2009, 06:50 PM
291 291 is offline
Registered User
 
Join Date: Jul 2009
Posts: 9
291 is on a distinguished road
Thanks a lot guys, I managed to get mine flashed and unbricked! I recommend copying over the latest .ini files from jaf version 1.98.64 and then you can just select 'use .INI' option and select the correct model, it then sorts all the firmware files out (provided they are in the C:\Program Files\Nokia\Phoenix\Products\RM-505). Then its just a case of timing, to turn the device on when it says. Took a few attempts.
All good. Thanks again everyone!

  #40  
Old 02-07-2009, 06:56 PM
davwil davwil is offline
Registered User
 
Join Date: Jan 2008
Posts: 15
davwil is on a distinguished road
It was a real pleasure to share the pain.

Now I would like to know why the NSU update broke the phone quite so badly.

Is it only vodafone N97's that have had this problem or is it more wide spread?

Cheers David

  #41  
Old 02-07-2009, 07:04 PM
nokion nokion is offline
Registered User
 
Join Date: Jul 2009
Posts: 4
nokion is on a distinguished road
Quote:
Originally Posted by Mike.mp View Post
Its up to you, but it wont harm phone now Take easy way, and IF it won't work, you already know how to fix it.
Fair point. I've done it now and the tone has returned. Still not getting any widgets though but that's not an issue really.

davwil, I think someone in this thread stated it happened to their 3 handset too.

  #42  
Old 02-07-2009, 08:17 PM
doggybs doggybs is offline
Registered User
 
Join Date: Jul 2009
Posts: 3
doggybs is on a distinguished road
Hi, My N97 is not bricked, but i am trying to install the last firmware.

I have followed the instructions above, but I am start with the phone turned on, and DEAD USB option unselected.

It re-boots the phone, and gets as far as stage 2, and the stops. I turn on the phone and it as if nothing has changed.

What am i doing wrong?

JAF version 1.98.62
Detected PKEY: 9000D75A
Card life counter: 99.99%
P-key nokia module version 01.02
FBUS INTERFACE NOT CONNECTED!!!
USB Cable Driver version: 7.1.16.0
Changing mode...Done!
Detected P-KEY: 9000D75A
P-key nokia module version 01.02
Init usb communication...
Reading product code...
Product Code: 0585262
Searching for JAF saved location of ini...
Checking path: C:\Program Files\Nokia\Phoenix\Products\RM-505\

Searching for default location of ini...
Checking path: \Products\RM-505\
Searching for JAF saved location of ini...
Checking path: C:\Program Files\Nokia\Phoenix\Products\RM-505\
Scanning ini files...
Searching for default location of ini...
Checking path: \Products\RM-505\
Checking path: C:\Program Files\Nokia\Phoenix\Products\RM-505\
FILES SET FOR FLASHING:
MCU Flash file: C:\Program Files\Nokia\Phoenix\Products\RM-505\RM-505_11.0.021_prd.core.C00
PPM Flash file: C:\Program Files\Nokia\Phoenix\Products\RM-505\RM-505_11.0.021_prd.rofs2.V01
CNT Flash file: C:\Program Files\Nokia\Phoenix\Products\RM-505\RM-505_11.0.021_C01_prd.rofs3.fpsx
APE Variant file: C:\Program Files\Nokia\Phoenix\Products\RM-505\RM505_507_11.0.021_uda1_001.uda.fpsx
Languages in ppm: English,German,Russian,Bulgarian,Romanian,Ukrainia n
Backing up CRT...
Detected P-KEY: 9000D75A
P-key nokia module version 01.02
Init usb communication...
Reading IMEI...
C:\Program Files\ODEON\JAF\ProgData\354225031224293_CRT_backu p_21527.pm
Done!
Backup CRT OK!
Detected P-KEY: 9000D75A
P-key nokia module version 01.02
Init usb communication...
Searching for phone...Found
Reading SW version...ICPR72_09w17.3 10.0.012
Reading battery value...4065 mV
Init usb flashing...
Reading flashid...
CMT: 004000EC <=> SAMSUNG (SEC) -> KAT00F00RA
APE: 00000000 <=> Flash -> not detected
Verifing ADL communication... Status byte 7
Rebooting to flash mode...
Waiting for the phone to reboot...
Searching for phone...
Sending RAW loader...
Using 009.008.003
Elf2flash 09.11.000
CMT RAW loader...
Patching RAW boot step1...
Patching RAW boot step2...
Patching RAW boot step3...
Sending RAW Loader...
....................Loader Sent!
Stage 2 starting...............

  #43  
Old 02-07-2009, 08:45 PM
doggybs doggybs is offline
Registered User
 
Join Date: Jul 2009
Posts: 3
doggybs is on a distinguished road
its ok i sorted it. It turns out you have to break your phone first, before you can upgrade lol.

So i changed the prod-code, used the nokia updator to break it, then JAF fixed it.

Winner. Cheers for the info guys.

  #44  
Old 03-07-2009, 02:19 AM
MrAaronVenn MrAaronVenn is offline
Registered User
 
Join Date: Jul 2009
Posts: 22
MrAaronVenn is on a distinguished road
Quote:
Originally Posted by 291 View Post
Thanks a lot guys, I managed to get mine flashed and unbricked! I recommend copying over the latest .ini files from jaf version 1.98.64 and then you can just select 'use .INI' option and select the correct model, it then sorts all the firmware files out (provided they are in the C:\Program Files\Nokia\Phoenix\Products\RM-505). Then its just a case of timing, to turn the device on when it says. Took a few attempts.
All good. Thanks again everyone!
What or where are these .INI files?
I've installed/copied whatever the latest JAF 1.98.64 .ini's over.
So when I click "use ini" yes, the N97 is listed.

Then it searches the folder and says there's nothing there.
Um, yes there is, there's the 14 files I downloaded off Navifirm.

I can paste them manually doing in order such as MCU, PPM, CNT whatever
but then it gets to "Pooling" and stops.

Whats happening?
If Nokia Care can't fix this phone i'm going to throw it off my local bridge.
I didn't pay $1000 to have a paperweight thanks to their suggested Software Upgrader that breaks your phone.

Last edited by MrAaronVenn; 03-07-2009 at 02:27 AM.

  #45  
Old 03-07-2009, 07:23 AM
LJS's Avatar
LJS LJS is offline
Registered User
 
Join Date: Jun 2009
Location: Plymouth, UK
Posts: 46
LJS is on a distinguished road
Quote:
Originally Posted by MrAaronVenn View Post
What or where are these .INI files?
I've installed/copied whatever the latest JAF 1.98.64 .ini's over.
So when I click "use ini" yes, the N97 is listed.

Then it searches the folder and says there's nothing there.
Um, yes there is, there's the 14 files I downloaded off Navifirm.

I can paste them manually doing in order such as MCU, PPM, CNT whatever
but then it gets to "Pooling" and stops.

Whats happening?
If Nokia Care can't fix this phone i'm going to throw it off my local bridge.
I didn't pay $1000 to have a paperweight thanks to their suggested Software Upgrader that breaks your phone.
I had the same issue after downloading the files through Navifirm, jaf just wouldn't find them. I then downloaded the image using phoenix and jaf then picked up the previous files, very bizarre.

Incidentally I probably wouldn't have had to use jaf if the damn NSU didn't hang halfway through the flashing process, damn you nokia and thank you jaf .
__________________
and there it was, GONE!
 

Bookmarks

Tags
bricked, n97

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
A Nokia N97 sort of day... slitchfield Links of Interest 50 08-10-2009 01:59 PM
Which Phone - N97, N86, or iPhone sjdean Nokia Nseries S60 5.0 phones (Nokia N97 and Nokia N97 mini) 15 04-09-2009 08:42 AM
N97 in The Netherlands... Gerco Nokia Nseries S60 5.0 phones (Nokia N97 and Nokia N97 mini) 1 29-06-2009 07:00 PM
Software for N97 rdcinhou Nokia Nseries S60 5.0 phones (Nokia N97 and Nokia N97 mini) 17 22-06-2009 08:31 PM
MWC: Symbian report: Nokia N97, Samsung Omnia HD, Sony Idou etc. Menneisyys S60 (Series 60) 2 20-02-2009 09:16 PM



All times are GMT. The time now is 12:46 PM.


vBulletin skins developed by: eXtremepixels
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright Notes || Contact Us || Privacy Policy