All About Symbian - Nokia (S60) and Sony Ericsson (UIQ) smartphones unwrapped

  #1  
Old 29-12-2004, 07:46 AM
Pankaj Mathur
Guest
 
Posts: n/a
Internet Sharing - WLAN (AD HOC mode)

Hi All,

This post might be useful to few who would like to utilize the WLAN capabilities of the 9500.
Scenario : I have a Centrino notebook with a LAN card and a Wireless card in built. The notebook has Windows XP professional loaded on it. The LAN card is connected to my office network through which we are able to access the internet. Thus I have created a ad hoc connection between my
notebook and the Nokia 9500 for internet access on my 9500, while I am in office.


if you have a similar situation....THIS IS WHAT YOU NEED TO DO:

The steps are as below:

1. Go to Control Panel > Network Connection and then right click the wireless card icon. Go to the wireless networks tab and below the preferred networks window click the add button. On the new form that opens, provide a network name, eg. WIRELESS, then change the network authentication to open and data encryption type to disabled. Additionally also tick the "This is a computer to computer (Ad Hoc) net....." option. On doing so click OK on the Wireless Network properties window and then on the wireless network connection properties window.

2. The LAN card is connected to the office network and has a preconfigured static IP address 192.168.1.75

3. After the LAN card has been configured to the office network, disconnect the network cable from the LAN card and go to Control Panel > Network Connection and then right click the LAN card icon. Go to the Advanced tab and enable internet connection sharing. Then click the settings button to enable the services that you would like to access on your Nokia 9500. For browsing and email at least enable HTTP, HTTPS, POP and SMTP. After that Click on OK on the Advanced Setting form and the Local Area connection properties form.

4. On doing this your wireless card would automatically be assigned an IP 192.168.0.1. (you don’t need to do anything here)

5. Now open the communicator interface of your Nokia 9500 and go to the control panel.

6. Navigate to connections and then to Wireless LAN (in the right Pane). Select wireless LAN and then go to the Networks tab. On Networks tab change the display to Ad HOC Networks. On changing to AD HOC networks you should see your notebook ad hoc connection with the name you defined in step 1.

7. Once you see your wireless ad hoc connection, press the “Create Access Point” button on the communicator (second button next to the screen). Create a access point and then press the done button.

8. Now in the control panel go to Connections and then navigate to “Internet Setup” in the right pane and select the same.

9. On the connections tab choose the access point that you just created and then press the edit button. Now press the “Advanced” button and navigate to the “IP Configuration” tab.
Following settings have to be set here:
Auto Retrieve IP: NO
IP Address: 192.168.0.2
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.0.1
Primary DNS: 192.168.0.1

That’s it….don’t change anything else. Just press the “DONE” button and come out.

Now open your browser and press the “Open Web Address” button and try a URL, say www.yahoo.com.
On doing so, you would be asked to choose a access point to connect. Choose the access point that you created earlier.

Does it work.
Do you see yahoo getting loaded.

Please write back for further clarifications.

  #2  
Old 06-01-2005, 02:06 PM
cgvanand cgvanand is offline
Registered User
 
Join Date: Jan 2005
Posts: 8
cgvanand is on a distinguished road
internet sharing

I have a laptop with wifi and connect to internet via lan.

i tried using your guidelines. i clicked the wirless card icon and gave a networkname. The network authentifcation (shared) only was there. ( there as no open option) and i selected it. i disabled data encryption type and ticked the adoc options.

But the problem came in the next step. onclicking the lan card icon i never got the advanced button at all. i could get only properties and some thing. at last i could not follow the steps of enabling pop,smtp etc. i have lan connection, wlan connection, 1394 connection and network bridge in the network connections.

I did other steps in the communicator and both the devices recogonises and wlan is on.

But i could not surf the net because i think wlan is not configured to an ip address.

can you suggest a solution.

one more question can you access anything or do sync or transfer files through adhoc connection.

anand

  #3  
Old 06-01-2005, 03:07 PM
pankajxmathur pankajxmathur is offline
Registered User
 
Join Date: Dec 2004
Posts: 12
pankajxmathur is on a distinguished road
Quote:
Originally Posted by cgvanand
I have a laptop with wifi and connect to internet via lan.

i tried using your guidelines. i clicked the wirless card icon and gave a networkname. The network authentifcation (shared) only was there. ( there as no open option) and i selected it. i disabled data encryption type and ticked the adoc options.

But the problem came in the next step. onclicking the lan card icon i never got the advanced button at all. i could get only properties and some thing. at last i could not follow the steps of enabling pop,smtp etc. i have lan connection, wlan connection, 1394 connection and network bridge in the network connections.

I did other steps in the communicator and both the devices recogonises and wlan is on.

But i could not surf the net because i think wlan is not configured to an ip address.

can you suggest a solution.

one more question can you access anything or do sync or transfer files through adhoc connection.

anand
Is your OS Windows Xp....if yes then with which Service Pack ????

  #4  
Old 06-01-2005, 03:39 PM
cgvanand cgvanand is offline
Registered User
 
Join Date: Jan 2005
Posts: 8
cgvanand is on a distinguished road
wlan adhoc

it is service pack one

should i install service pack 2

can i browse other files through wlan or only internet sharing

thanks for the help

  #5  
Old 07-01-2005, 01:33 PM
black`phoenix's Avatar
black`phoenix black`phoenix is offline
Registered User
 
Join Date: Nov 2004
Posts: 18
black`phoenix is on a distinguished road
Smile

Quote:
Originally Posted by Pankaj Mathur
Hi All,

3. After the LAN card has been configured to the office network, disconnect the network cable from the LAN card and go to Control Panel > Network Connection and then right click the LAN card icon. Go to the Advanced tab and enable internet connection sharing. Then click the settings button to enable the services that you would like to access on your Nokia 9500. For browsing and email at least enable HTTP, HTTPS, POP and SMTP. After that Click on OK on the Advanced Setting form and the Local Area connection properties form.

I cant browse the internet thru my phone? but i can see the W sign in there. Should I reconnect the network cable from the LAN or what?

Thanks.
__________________
Every beginning has an end...

Last edited by black`phoenix; 07-01-2005 at 01:36 PM.

  #6  
Old 23-01-2005, 11:26 PM
VaRaTel VaRaTel is offline
Registered User
 
Join Date: Jan 2005
Posts: 1
VaRaTel is on a distinguished road
Hi Pankaj,
Thanks for the very well drafted info,these things are never drafted and left for the end user to struggle to find out.If these kind of info is available in user guides,it would be very beneficial to customers.


I have quite similar question for discussion :

1.Could I browse the internet on laptop with following conditions or am I stupid to think like this ?
a.laptop & 9500 are connected in WLAN adhoc (quite similar to what you said) but now primary DNS being the 9500(which could act also like the default gateway)
b.use 9500 GPRS

is it possible ?

Cheers,-Va

  #7  
Old 14-02-2005, 09:40 AM
TheJoker TheJoker is offline
Registered User
 
Join Date: Oct 2004
Location: Near Oxford
Posts: 170
TheJoker is on a distinguished road
Cool Doesn't work for me

Hiya,

Finally got round to trying this, but the directions are a bit confusing.

Point 1:
----
1. Go to Control Panel > Network Connection and then right click the wireless card icon. Go to the wireless networks tab and below the preferred networks window click the add button.
---
I don't have such tab, and usually when I right click I need to select a sub-menu, which one in this case?

Also, point number two:
Instructions state to enable Internet Connection Sharing (ICS) on the LAN card (not WLAN), and thus it would give the WLAN card 192.168.0.1 IP number - this is incorrect :( It is the network card that has got ICS enable that gets 192.168.0.1 IP number, and I would need to enable ICS on the LAN card, which in turn would give LAN card 192.168.0.1 IP number - this I can't do on my workstation, as there already is a computer on the network that is configured as gateway.


This is how I've solved it (I managed while writing this!)

Copy the LAN cards setting to your WLAN card on your computer, except for that you give the WLAN card another IP number - I just "made one up" and there doesn't seem to be any conflicts *knock-on-wood*!

Then when you have the WLAN and LAN cards set up, select both and right-click and select bridge networks. I now had to enter the LAN cards IP details again (don't know how to configure it "out of the box" - i.e without configuring the WLAN card first).

I set the security up with the software that came with the WLAN card, so I'm running WEP encryption etc.

Then on the 9500 set the IP configuration to the same as you WLAN card, except give the 9500 a different IP number (you'll end up using 2 IP numbers).

If all settings are correct, you should now be able to use the internet from you 9500 via the Ad-Hoc network bridge.

  #8  
Old 15-02-2005, 08:40 AM
TheJoker TheJoker is offline
Registered User
 
Join Date: Oct 2004
Location: Near Oxford
Posts: 170
TheJoker is on a distinguished road
Thumbs down

.... GRrrrrr... Grrrrr!!!

I can't get it to work; I'm stumped, I give up, no more cr*%, Bill...

Sometimes I can browse the net by entering IP number... Once in a while, I've even managed to load up a page by using normal domain names. But never for long... I can always ping the 9500 from the WinXP machine...

I give up on this Windows-trial-by-error-administration... Grrrrr... At least in Unix-world you'd go away and read an O'Reilly book or a big mofo how-to, then come back and fix it... but this Windows cr&^ is just pure cr^%...

I'd be very pleased if anyone out there would have any ideas!

  #9  
Old 18-02-2005, 11:59 AM
kbmotoomull kbmotoomull is offline
Registered User
 
Join Date: Feb 2005
Posts: 2
kbmotoomull is on a distinguished road
wow! it is working... BUT...

Quote:
Originally Posted by TheJoker
Hiya,

Finally got round to trying this, but the directions are a bit confusing.

Point 1:
----
1. Go to Control Panel > Network Connection and then right click the wireless card icon. Go to the wireless networks tab and below the preferred networks window click the add button.
---
I don't have such tab, and usually when I right click I need to select a sub-menu, which one in this case?

Also, point number two:
Instructions state to enable Internet Connection Sharing (ICS) on the LAN card (not WLAN), and thus it would give the WLAN card 192.168.0.1 IP number - this is incorrect :( It is the network card that has got ICS enable that gets 192.168.0.1 IP number, and I would need to enable ICS on the LAN card, which in turn would give LAN card 192.168.0.1 IP number - this I can't do on my workstation, as there already is a computer on the network that is configured as gateway.


This is how I've solved it (I managed while writing this!)

Copy the LAN cards setting to your WLAN card on your computer, except for that you give the WLAN card another IP number - I just "made one up" and there doesn't seem to be any conflicts *knock-on-wood*!

Then when you have the WLAN and LAN cards set up, select both and right-click and select bridge networks. I now had to enter the LAN cards IP details again (don't know how to configure it "out of the box" - i.e without configuring the WLAN card first).

I set the security up with the software that came with the WLAN card, so I'm running WEP encryption etc.

Then on the 9500 set the IP configuration to the same as you WLAN card, except give the 9500 a different IP number (you'll end up using 2 IP numbers).

If all settings are correct, you should now be able to use the internet from you 9500 via the Ad-Hoc network bridge.
Hi!

I was able to follow all your instructions and it works fine... wow! the internet is quite fast...

but one problem, while the "bridge" connection is on, the internet browsing in my laptop does not work. if i delete the "bridge connection" it works again.

if this is valid, this means you can only browse at one device at a time. it is either you use your laptop/desktop or your 9500.

right?

if we get both worlds, i would be greatly amazed!

kernan

  #10  
Old 18-02-2005, 12:04 PM
kbmotoomull kbmotoomull is offline
Registered User
 
Join Date: Feb 2005
Posts: 2
kbmotoomull is on a distinguished road
can we have both worlds?

forgot to ask... can we have both worlds?

  #11  
Old 18-02-2005, 12:35 PM
TheJoker TheJoker is offline
Registered User
 
Join Date: Oct 2004
Location: Near Oxford
Posts: 170
TheJoker is on a distinguished road
Beer

Quote:
Originally Posted by kbmotoomull
forgot to ask... can we have both worlds?
Kernan,

You should be able to configure your laptop to be able to use the Internet, but I'm fresh out of skills on this area.

Can you try to resolve the IP number for Google (google.co.uk - 216.239.59.104), and see if you can use your laptop to surf to Google using the IP number?

I believe that
a) Either you can't have both worlds (for some strange reason)
b) There's a problem with one machine connecting while in a bridge


Not much help is it... :( I've kind of given up on the subject as I can't figure out why I get a TCP/IP connection between my workstation and my 9500. The 9500 answers to ping from the workstation. But I can't surf the web from the 9500 :(
It's driving me crazy!

  #12  
Old 10-03-2005, 07:04 PM
stubby stubby is offline
Registered User
 
Join Date: Mar 2005
Posts: 35
stubby is on a distinguished road
Quote:
Originally Posted by kbmotoomull
Hi!

I was able to follow all your instructions and it works fine... wow! the internet is quite fast...

but one problem, while the "bridge" connection is on, the internet browsing in my laptop does not work. if i delete the "bridge connection" it works again.

if this is valid, this means you can only browse at one device at a time. it is either you use your laptop/desktop or your 9500.

right?

if we get both worlds, i would be greatly amazed!

kernan
I got my 9500 set up with my Vaio with 802.11b built in. It works brilliantly, and browsing from the 9500 is very fast and faster than GPRS as far as I can see.
My internet connection is shared between both devices and I can use both at the same time over the same connection. It is pretty seamless, but the range is limited and I find the signal drops between one end of my house to the other.

But being able to browse anytime from my 9500 without running up a huge GPRS bill makes me smile.

  #13  
Old 11-05-2006, 09:25 PM
Spinstorm Spinstorm is offline
Registered User
 
Join Date: May 2006
Posts: 1
Spinstorm is on a distinguished road
I have a N91 Nokia and a Vaio Laptop and can't get a ad hoc connection to work!

I believe I have set up the phone AND the laptop (XP Media Centre) right but it doesn't want to work! Please help!

  #14  
Old 16-09-2006, 01:49 PM
ausheikh ausheikh is offline
Registered User
 
Join Date: Sep 2006
Posts: 3
ausheikh is on a distinguished road
Ad hoc connections with E61

Has anyone tried this procedure on an E61. I tried it on mine, and it works fine until i exit the browser, my phone restarts. Same happens when I try to download my mail ( I use profimail).

Any ideas?

  #15  
Old 14-10-2006, 09:06 PM
alessliber alessliber is offline
Registered User
 
Join Date: Oct 2006
Posts: 2
alessliber is on a distinguished road
Nokia E61

Hi ausheikh,

I'm trieng to connect my Nokia E61 to WLAN on my notebook.
But I can not connect, on the phone appears: wrong default gateway.
After that my phone also restart like yours (white screen).

Probably I have done something wrong with TCP/IP settings.
They are like this:

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . : 192.168.1.2
Subnet Mask . . . . . . . . . . . : 255.255.255.0
IP Address. . . . . . . . . . . . : fe80::290:f5ff:fe39:e77%5
Default Gateway . . . . . . . . . : 192.168.1.1

Ethernet adapter Wireless Network Connection:

Media State . . . . . . . . . . . : Media disconnected

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . : 2001:0:4136:e37a:8000:7fb0:3eb2:6ba1

IP Address. . . . . . . . . . . . : fe80::ffff:ffff:fffd%4
Default Gateway . . . . . . . . . : ::

Tunnel adapter Automatic Tunneling Pseudo-Interface:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . : fe80::5efe:192.168.1.2%2
Default Gateway . . . . . . . . . :


I create then an "ad hoc" connection with my oven WAP key.
The TCP settings from Wlan connection are:


IP Address. . . . . . . . . . . . : 192.168.0.2
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1


And on the Nokia E61 I also create static IP:


IP Address. . . . . . . . . . . . : 192.168.0.3
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1


This configuration does not work.
I have also enabled on LAN connection, that other ussers can connect throug it.
So I get default gateway IP for those connection who connect through it (192.168.0.1).
Also by WLAN connection I have create ad hock connection and in advanced icon I have choose: computer to computer network.
My Windows are: XP+SP2

Does anybody hav any idea what should be wrong??

Ales S.
Ads
 

Bookmarks

Tags
hoc, internet, mode, sharing, wlan

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bluetooth Internet Sharing? Boeky Nokia 7650 14 05-08-2005 11:58 AM
Internet Sharing.. via USB cable? bobsickal Nokia 7610 and 6670 0 26-10-2004 11:35 AM
Internet Connection Sharing with Bluetooth/irDA/USB Cable JBaughb Sony Ericsson P800, P900 and P910 1 14-07-2004 10:27 PM
Apple Mac Bluetooth/ Cable/ Internet Sharing Sony Ericsson P800, P900 and P910 2 14-06-2004 12:50 PM
GPRS Internet Sharing with notebook Tigerdyr2 Sony Ericsson P800, P900 and P910 2 02-07-2003 12:48 PM



All times are GMT. The time now is 07:22 AM.


vBulletin skins developed by: eXtremepixels
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright Notes || Contact Us || Privacy Policy