All About Symbian - Nokia (S60) and Sony Ericsson (UIQ) smartphones unwrapped

Go Back   All About Symbian Forums > News and Comments > Series 60

 
 
Thread Tools Display Modes

  #1  
Old 04-06-2008, 06:17 AM
slitchfield slitchfield is offline
Administrator
 
Join Date: Nov 2002
Posts: 7,002
slitchfield is on a distinguished road
'Fixing' Flash Lite 3 on the Nokia E90

You'll recall that the Nokia E90 Communicator recently received a major official firmware update, to v210.34.75, as reported by me here. This brought the E90 into a pretty mature state apart from the fact that Web's Flash integration seemed horribly broken, but only for some people. Read on for my investigation...

Read on in the full article.

  #2  
Old 04-06-2008, 07:07 AM
Arjen's Avatar
Arjen Arjen is offline
Administrator
 
Join Date: Apr 2004
Location: Netherlands
Posts: 428
Arjen is on a distinguished road
Good tip Steve, thanks. Since Flash isn't working on my phone either I'll try this as well on my E90 and post the results here, although I'm not really looking forward to re-installing everything

My 2 cents for the reasons that this works is that the Flash libraries need to be initialized before you install a lot of third party applications or synchronize your phone with PCSuite for example. With this fix, the first thing you do after the format is checking whether or not Flash works. Since the internal disk is almost almost empty at that time, the libraries get initialized properly. And, since they were initialized properly, Flash will continue working even if you installing lots of other stuff afterwards

If you first install all your third party apps or maybe do a sync using PCSuite and then try to run Flash for the first time, for example by trying to play a video on Youtube, apparently something prevents the libraries from being installed correctly, causing a browser crash.
__________________
This space intentionally left blank.

  #3  
Old 04-06-2008, 09:21 AM
tozman tozman is offline
Registered User
 
Join Date: Apr 2008
Location: Aix en Provence (France)
Posts: 1
tozman is on a distinguished road
It worked too

Hi everyone, I had the same problem with bugs on FL3, hard resetting the phone made it work right. Thanks a lots for the tip.

  #4  
Old 04-06-2008, 04:54 PM
phillips6549 phillips6549 is offline
Registered User
 
Join Date: Apr 2008
Location: Birmingham, UK
Posts: 11
phillips6549 is on a distinguished road
flashlite 3 question

its intersting to hear that FL3 is able to play videos on YouTube but will it play the streaming content on BBC IPlayer?
Mark.

  #5  
Old 04-06-2008, 05:02 PM
Mr-X
Guest
 
Posts: n/a
Yes, this is something I would also like to know.

The screen on the N95 8GB is too low in resolution so BBC iPlayer doesn't really work with it. Since the E90's resolution is considerably higher I think it will probably work. Could you please try it out, Steve?

  #6  
Old 04-06-2008, 06:42 PM
Arjen's Avatar
Arjen Arjen is offline
Administrator
 
Join Date: Apr 2004
Location: Netherlands
Posts: 428
Arjen is on a distinguished road
My 2 cents weren't worth a penny . It's not the additional stuff that makes the Flash unable to work in the browser.

Like Steve said before: it either works after a reformat or doesn't. In my case after reformatting and rebooting the browser still didn't display Flash content (it crashed as soon as the Flash player got loaded from a Youtube webpage). So I did another *#7370# and after that the browser played the Flash content happily. Now after restoring the backup I made and installing the applications it failed to restore (I wonder when Nokia is going to fix that) Flash content is still playing perfectly in the web browser.
__________________
This space intentionally left blank.

  #7  
Old 04-06-2008, 09:25 PM
slitchfield slitchfield is offline
Administrator
 
Join Date: Nov 2002
Posts: 7,002
slitchfield is on a distinguished road
The iPlayer picture is fine - though I tend to run Flash videos 'full screen' anyway. Unfortunately, the BBC's servers don't really pick up on the fact that a phone is being used and the streaming's not properly optimised, meaning that the frame rate is often unwatchable and the sound breaks up from time to time.

Shame really. BBC - please wake up to the fact that S60 phones would like in on the iPlayer action! 8-)

Steve
__________________
Steve Litchfield, Admin, AAS

  #8  
Old 05-06-2008, 04:25 AM
Jonek
Guest
 
Posts: n/a
@ Steve. What theme are you using ? It looks really good. I also wonder how you get such a big icon for the Gmail-app, mine is relly tiny.

  #9  
Old 05-06-2008, 06:10 AM
slitchfield slitchfield is offline
Administrator
 
Join Date: Nov 2002
Posts: 7,002
slitchfield is on a distinguished road
Theme is PiZero's commercial 'Fire', btw
__________________
Steve Litchfield, Admin, AAS

  #10  
Old 05-06-2008, 06:12 AM
Unregistered
Guest
 
Posts: n/a
I can play youtube.com videos, but they are palyed via RelPlayer (when I choose the link, the RealPlayer starts). Is it ok, or they should be played directly in the browser with FlashLite3?

  #11  
Old 05-06-2008, 06:29 AM
Arjen's Avatar
Arjen Arjen is offline
Administrator
 
Join Date: Apr 2004
Location: Netherlands
Posts: 428
Arjen is on a distinguished road
That's probably because you're using the mobile version of Youtube. To play the video in the browser, scroll down in the web browser to the bottom of the screen and select the link for the "desktop version" of Youtube. Works great in the E90 browser.
__________________
This space intentionally left blank.

  #12  
Old 05-06-2008, 07:51 AM
Unregistered
Guest
 
Posts: n/a
I checked the Nokia website, but it is still stuck at the old release...

  #13  
Old 05-06-2008, 11:11 AM
siausin siausin is offline
Registered User
 
Join Date: May 2008
Posts: 6
siausin is on a distinguished road
The new firmware is buggy, think first before you upgrade..totally mess up my E90 GPS...now cannot get GPS fix..even in open sky with no blockage at all...

  #14  
Old 05-06-2008, 11:32 AM
slitchfield slitchfield is offline
Administrator
 
Join Date: Nov 2002
Posts: 7,002
slitchfield is on a distinguished road
GPS is fine. It's just that you'll have lost your access points with the upgrade. Check your data connection and check that Nokia Maps is using it for Assisted GPS etc.
__________________
Steve Litchfield, Admin, AAS
Ads

  #15  
Old 05-06-2008, 12:19 PM
Onno Ephraim Onno Ephraim is offline
Registered User
 
Join Date: Jul 2007
Posts: 1
Onno Ephraim is on a distinguished road
I'm not sure you're right. After I upgraded my E90 fails to get a fix from time to time. Most of the time it works just fine, but once in - say - five to eight attempts it fails. I can't figure out why, but after a reboot everything is fine again; and fast due to the AGPS.
 

Bookmarks

Tags
e90, fixing, flash, lite, nokia

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[HOT][NEW] N80 RM-92 IE APAC PR v15.00 SW4.0632.0.38 juato4 Nokia N80 176 25-04-2007 03:19 PM



All times are GMT. The time now is 04:57 PM.


vBulletin skins developed by: eXtremepixels
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright Notes || Contact Us || Privacy Policy