All About Symbian - Nokia (S60) and Sony Ericsson (UIQ) smartphones unwrapped

  #1  
Old 14-04-2010, 04:07 PM
jamessmith01 jamessmith01 is offline
Registered User
 
Join Date: Jul 2009
Posts: 151
jamessmith01 is on a distinguished road
Error when connecting to IMAP mail server - untrusted certificate

I am using a Nokia N97 with the v21 firmware.

I am connecting to a mail server via IMAP, using the phone's mail client. This has previously worked perfectly, however now I cannot update my inbox and view the emails.

When I try to update the inbox, I get a dialogue box that says "Website has sent an untrusted certificate". After choosing "accept permanently", the inbox does not update. The message comes up every time I try to update (even when I've previously chosen "accept permanently".

I can however successfully send emails via the SMTP server using the phone (IMAP for sending is restricted, so have to use SMTP).

Does anyone have any ideas on why this is happening, and how I can solve it? I've also contacted the IT guys for the mail server, as I'm not sure whether the problem lies with the mail server or the phone, or both.

  #2  
Old 14-04-2010, 09:44 PM
matthewrleech's Avatar
matthewrleech matthewrleech is offline
Registered User
 
Join Date: Aug 2009
Location: United Kingdom
Posts: 234
matthewrleech is on a distinguished road
IMAP security

I seem to remember having a similar problem with the N97 built-in mail client and the answer being something to do with the IMAP SSL method. Which are you using?

None
SSL/TLS
StartTLS

I always use None.
__________________
Thank goodness for Opera!

  #3  
Old 15-04-2010, 05:30 AM
jerm's Avatar
jerm jerm is offline
Registered User
 
Join Date: Sep 2009
Posts: 332
jerm is on a distinguished road
i cant remember where i saw it, but methinks you can import the certificate into your 97...somehow. i think you need to open the site on normal browser, then save the cert and copy to your phone and install it...somehow.

sorry, not much help here haha
__________________
....hello, N8

  #4  
Old 15-04-2010, 09:19 AM
jamessmith01 jamessmith01 is offline
Registered User
 
Join Date: Jul 2009
Posts: 151
jamessmith01 is on a distinguished road
Using SSL/TLS - the mail server doesn't allow unsecured connections. Will try the browser thing and report back, cheers.

Edit: The web access page for the mail account opens fine in the Nokia browser - no mention of a certificate. One thing I noticed is the URL has changed from https:// to http:// - whether this is important I don't know, but it's weird that they changed it.

Also to add, there are discussion on Nokia Discussions about viewing and changing certificates for mail accounts using Mail for Exchange or Nokia Messaging. However I'm not using either, only the in-built client. Looks like I might have to install a 3rd-party mail app.

Last edited by jamessmith01; 15-04-2010 at 09:28 AM.

  #5  
Old 15-04-2010, 09:35 AM
matthewrleech's Avatar
matthewrleech matthewrleech is offline
Registered User
 
Join Date: Aug 2009
Location: United Kingdom
Posts: 234
matthewrleech is on a distinguished road
Quote:
Originally Posted by jamessmith01 View Post
Looks like I might have to install a 3rd-party mail app.
Profimail is my strong recommendation.
__________________
Thank goodness for Opera!

  #6  
Old 15-04-2010, 10:45 AM
jamessmith01 jamessmith01 is offline
Registered User
 
Join Date: Jul 2009
Posts: 151
jamessmith01 is on a distinguished road
Quote:
Originally Posted by matthewrleech View Post
Profimail is my strong recommendation.
Does it support HTML, images, etc? And will it notify me when new mail arrives with an icon in the status bar area, or will only the built-in app do that?

Thanks.

  #7  
Old 15-04-2010, 12:46 PM
matthewrleech's Avatar
matthewrleech matthewrleech is offline
Registered User
 
Join Date: Aug 2009
Location: United Kingdom
Posts: 234
matthewrleech is on a distinguished road
Profimail features

Quote:
Originally Posted by jamessmith01 View Post
Does it support HTML, images, etc? And will it notify me when new mail arrives with an icon in the status bar area, or will only the built-in app do that?

Thanks.
HTML - yes (HTML is supported for for reading incoming emails, outgoing emails are always plain text)
Images - yes
Notification - yes, as an icon in the top right corner

Lots of other features too but you're better off reading them on the lonelycat website.

http://www.lonelycatgames.com/?app=profimail
__________________
Thank goodness for Opera!

  #8  
Old 15-04-2010, 01:26 PM
jamessmith01 jamessmith01 is offline
Registered User
 
Join Date: Jul 2009
Posts: 151
jamessmith01 is on a distinguished road
Cheers for the info.

  #9  
Old 19-04-2010, 02:13 PM
jamessmith01 jamessmith01 is offline
Registered User
 
Join Date: Jul 2009
Posts: 151
jamessmith01 is on a distinguished road
Well I get the same certificate error on Profimail as with Nokia's built-in client. It looks like this is a problem specifically with the email server's certificate and/or the N97's handling of the certificate. I guess what I need is some way to manually install the certificate... any ideas?

Okay I just re-opened Profimail and it now reads the emails fine. Don't know what exactly is going on!

Last edited by jamessmith01; 19-04-2010 at 02:15 PM.

  #10  
Old 20-04-2010, 09:20 AM
jamessmith01 jamessmith01 is offline
Registered User
 
Join Date: Jul 2009
Posts: 151
jamessmith01 is on a distinguished road
I am able to access this email account using Profimail. I tried to access the account with Nokia Messaging, but it kept giving an error message, "Unable to connect with the information provided". Tried out Profimail and I'm not sure I like the sloppy interface and lack of integration to the rest of the system. The new mail notification pops up over the other icons in the corner!

  #11  
Old 22-04-2010, 09:36 AM
jamessmith01 jamessmith01 is offline
Registered User
 
Join Date: Jul 2009
Posts: 151
jamessmith01 is on a distinguished road
Update: I'm currently using Profimail, as it's the only IMAP client that can access my email account. The only other way to access it is by using a client connecting by exchange or outlook web access (e.g. emoze).

Of note, I still get the certificate error on Profimail, but only when I connect via WLAN (I'm currently using my work WLAN, which is WPA-secured - could this be a possible cause?). I had this set above the three UK connection in my internet destinations, so if I used "Internet" in Profimail, it also got the certificate error. For now I'm just setting the connection to use three UK only.

(The built-in email client still get the certificate error whether I connect by WLAN or three UK).

Last edited by jamessmith01; 22-04-2010 at 09:38 AM.

  #12  
Old 22-04-2010, 11:41 AM
matthewrleech's Avatar
matthewrleech matthewrleech is offline
Registered User
 
Join Date: Aug 2009
Location: United Kingdom
Posts: 234
matthewrleech is on a distinguished road
Does anything look out out of place in Settings->Phone->Phone mgmt.->Security->Certificate Management ?

On my phone I have lots (about 5 pages) of authorities listed in Authority certificates, the other three sections (Trusted, Personal and Phone) are all empty.
__________________
Thank goodness for Opera!
Ads

  #13  
Old 23-04-2010, 01:33 PM
jamessmith01 jamessmith01 is offline
Registered User
 
Join Date: Jul 2009
Posts: 151
jamessmith01 is on a distinguished road
I had a look through the certificates in there, but not really sure what to look for?

  #14  
Old 28-07-2010, 05:11 AM
akgx6 akgx6 is offline
Registered User
 
Join Date: Jul 2010
Posts: 1
akgx6 is on a distinguished road
check for expired ceritificates

Check the certificates mentioned in the path mentioned above by matthewrleech. When I hit this problem, I checked the certificate from my mail server inside 'Trusted Site Certificates'. The certificate details showed the valid upto date to a past date. I checked with our mail server administrator and he had already updated the certificate on the mail server. So, I deleted the certificate on my phone and allowed the phone to re-fetch and re-store the new certificate. Voila! everything is working great now.

  #15  
Old 28-07-2010, 11:16 AM
jamessmith01 jamessmith01 is offline
Registered User
 
Join Date: Jul 2009
Posts: 151
jamessmith01 is on a distinguished road
Quote:
Originally Posted by akgx6 View Post
Check the certificates mentioned in the path mentioned above by matthewrleech. When I hit this problem, I checked the certificate from my mail server inside 'Trusted Site Certificates'. The certificate details showed the valid upto date to a past date. I checked with our mail server administrator and he had already updated the certificate on the mail server. So, I deleted the certificate on my phone and allowed the phone to re-fetch and re-store the new certificate. Voila! everything is working great now.
Thanks for the advice - I've checked the certificate, but it's supposedly valid until 2013. It's very weird behaviour; sometimes the certificate is fine, others not. It doesn't seem to save the same certificate for long. It also doesn't work sometimes on Profimail either, now. Annoying.
 

Bookmarks

Tags
certificate, connecting, error, imap, mail, server, untrusted

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to: Get push GMail for free slitchfield Series 80 52 26-02-2010 03:47 PM
Connecting Mail For Exchange to an Exchange 2007 Server OliverCTS Nokia N95 and N95 8GB 1 23-08-2009 10:04 AM
MAIL: N70 / TLS (IMAP/SMTP) W/Self Signed Certificate -hicks- Nokia N70, N72 and N90 0 05-04-2006 08:10 PM
how can i configure my email in secure outgoing mail server? mjsee Nokia 7650 7 08-11-2002 03:51 PM



All times are GMT. The time now is 08:42 AM.


vBulletin skins developed by: eXtremepixels
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright Notes || Contact Us || Privacy Policy