All About Symbian - Nokia (S60) and Sony Ericsson (UIQ) smartphones unwrapped

  #1  
Old 19-08-2009, 12:08 PM
OliverCTS OliverCTS is offline
Registered User
 
Join Date: Aug 2009
Posts: 1
OliverCTS is on a distinguished road
Connecting Mail For Exchange to an Exchange 2007 Server

Hi All,

I am trying to setup a number of Nokia handsets (N95 8GB, E71, E75, etc) to connect to an Exchange 2007 server running on Windows Server 2008.

They will all be using Mail For Exchange and Active Sync to connect to the server however I am having troubles.

I have the latest firmware on all the handsets and Mail for Exchange version 2.9.

For some reason, no matter what I try, whenever I try and connect the handsets to the exchange server I get the message "Connection Error, Please try again later". I can connect them to an Exchange 2003 server running on Windows Server 2003 with no problems what so ever.

I have installed succesfully an SSL certificate (provided by GoDaddy) on the Exchange 2007 platform and I can access the exchange server by every other method (outlook, owa, etc) with no problems, the SSL certificate works perfectly.

Here is the admin_log1.txt information on the failure:

19/08/2009 12:07:17 Setting OFFLINE Status to False
19/08/2009 12:07:17 Setting DISK FULL status to False
19/08/2009 12:08:32 Profile deleted
19/08/2009 12:17:36 PeakTime active
19/08/2009 12:17:36 Setting OFFLINE Status to False
19/08/2009 12:17:37 PING Command Requested
19/08/2009 12:17:37 Delay the connection to server.
19/08/2009 12:17:37 Setting DISK FULL status to False
19/08/2009 12:18:18 Profile Updated
19/08/2009 12:18:18 Cancel Job:0, Type:"PING Job- Always-Online":
19/08/2009 12:18:18 unable to open snapshot database (-1)
19/08/2009 12:18:18 PeakTime active
19/08/2009 12:21:01 HTTP Server Error 408 : Request Timeout
19/08/2009 12:32:17 PeakTime active
19/08/2009 12:37:04 PeakTime active
19/08/2009 12:37:05 Setting OFFLINE Status to False
19/08/2009 12:37:05 Setting DISK FULL status to False
19/08/2009 12:42:35 PeakTime active
19/08/2009 12:42:35 Setting OFFLINE Status to False
19/08/2009 12:42:35 Setting DISK FULL status to False
19/08/2009 12:46:00 HTTP Server Error 408 : Request Timeout

Further to that, I also tested my exchanges activesync with http://www.testexchangeconnectivity.com/ and it works perfectly.

Can anyone help me?

Thanks,

Oliver

Last edited by OliverCTS; 19-08-2009 at 12:17 PM. Reason: added test website

  #2  
Old 23-08-2009, 10:04 AM
Retty Retty is offline
Registered User
 
Join Date: Jul 2009
Posts: 21
Retty is on a distinguished road
Quote:
Originally Posted by OliverCTS View Post
Hi All,

I am trying to setup a number of Nokia handsets (N95 8GB, E71, E75, etc) to connect to an Exchange 2007 server running on Windows Server 2008.

They will all be using Mail For Exchange and Active Sync to connect to the server however I am having troubles.

I have the latest firmware on all the handsets and Mail for Exchange version 2.9.

For some reason, no matter what I try, whenever I try and connect the handsets to the exchange server I get the message "Connection Error, Please try again later". I can connect them to an Exchange 2003 server running on Windows Server 2003 with no problems what so ever.

I have installed succesfully an SSL certificate (provided by GoDaddy) on the Exchange 2007 platform and I can access the exchange server by every other method (outlook, owa, etc) with no problems, the SSL certificate works perfectly.

Here is the admin_log1.txt information on the failure:

19/08/2009 12:07:17 Setting OFFLINE Status to False
19/08/2009 12:07:17 Setting DISK FULL status to False
19/08/2009 12:08:32 Profile deleted
19/08/2009 12:17:36 PeakTime active
19/08/2009 12:17:36 Setting OFFLINE Status to False
19/08/2009 12:17:37 PING Command Requested
19/08/2009 12:17:37 Delay the connection to server.
19/08/2009 12:17:37 Setting DISK FULL status to False
19/08/2009 12:18:18 Profile Updated
19/08/2009 12:18:18 Cancel Job:0, Type:"PING Job- Always-Online":
19/08/2009 12:18:18 unable to open snapshot database (-1)
19/08/2009 12:18:18 PeakTime active
19/08/2009 12:21:01 HTTP Server Error 408 : Request Timeout
19/08/2009 12:32:17 PeakTime active
19/08/2009 12:37:04 PeakTime active
19/08/2009 12:37:05 Setting OFFLINE Status to False
19/08/2009 12:37:05 Setting DISK FULL status to False
19/08/2009 12:42:35 PeakTime active
19/08/2009 12:42:35 Setting OFFLINE Status to False
19/08/2009 12:42:35 Setting DISK FULL status to False
19/08/2009 12:46:00 HTTP Server Error 408 : Request Timeout

Further to that, I also tested my exchanges activesync with http://www.testexchangeconnectivity.com/ and it works perfectly.

Can anyone help me?

Thanks,

Oliver
Obvious question but what are the settings you are using on the phones?

Akham's Razor and all that...

I managed to get hold of a config script for organisation specific Mail for Exchange settings - my manual set-up just wouldn't work.

I still can't see any difference at all between the script settings and my manual settings but whilst the manual settings did not work the script settings did. To satisfy my curiosity I've even re-entered the manual settings just to see if I was making a typo somewhere. Nothing obvious.

That said isn't it the case that Mail for Exchange on N Series phones does not support the full/advanced Exchange security set? Recent versions of N Series Mail for Exchange might have "fixed" that. On the E Series I believe it does and always did.
Ads
 

Bookmarks

Tags
2007, activesync, connecting, exchange, mail, mailforexchange, mfe, server

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail for Exchange 2.9 is out bchliu Nokia Eseries S60 3.1 Phones (2nd Generation: E51, E66, E71) 3 11-06-2009 07:41 PM
Seamless wifi for Mail for Exchange on e71 philiptoews Nokia Eseries S60 3.1 Phones (2nd Generation: E51, E66, E71) 1 12-11-2008 06:03 AM
Mail for Exchange gets fixed 2007 SP1 compatibility slitchfield Links of Interest 0 08-07-2008 08:13 AM
Mail For Exchange - Not Connecting Terry1100 Nokia Eseries S60 3.0 phones (E50, E60, E62, E61, E61i, E70) 1 08-12-2007 01:40 AM
Nokia Licence MS Exchange Server Active Sync Technologies Ewan Symbian OS News 0 14-02-2005 08:38 AM



All times are GMT. The time now is 11:50 PM.


vBulletin skins developed by: eXtremepixels
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright Notes || Contact Us || Privacy Policy