All About Symbian - Nokia (S60) and Sony Ericsson (UIQ) smartphones unwrapped

  #1  
Old 25-10-2004, 07:41 PM
ukguy4672 ukguy4672 is offline
Registered User
 
Join Date: Oct 2004
Posts: 2
ukguy4672 is on a distinguished road
Thumbs down More than one IMEI???

I recently purchased a Sony Ericsson P910i. I have had it just over a week now and am very happy with it.

I decided to install some useful apps such as SMan, demo versions of Handy Safe and Tracker. I quite liked Tracker so thought I would purchase the full product. I registered my details using my IMEI number with SymbianWare. (as displayed on the back of my handset behind the battery)

I received an email today with my registration key and set about registering my version of Tracker. When I opened the registration window I noticed that the IMEI number displayed was different to the IMEI number that I had registered with.

Since the registration key is generated using the IMEI number, when I entered the registration key, I got a 'code error' message.

I double checked the IMEI number on my handset, the handset box and by dialling *#06#. The IMEI number was the same in all 3 cases.

The IMEI number in the sysinfo utility in SMan and the registration window in Tracker are the same BUT different to the above. I installed another demo app and again the IMEI number was the same as in SMan and Tracker but different to the IMEI displayed on my handset/box.

I am rather confused as to why this is. It was my understanding that the IMEI number is unique to any given handset. So how can there possibly be 2 different IMEI numbers associated with my handset??

Has anyone else noticed the same? Any help/feedback would be really helpful.

  #2  
Old 11-11-2004, 07:38 PM
brownboy
Guest
 
Posts: n/a
I have the same problem and apparently it's a common problem with the P910i's
SE are aware of it and are trying to figure out whats causing it.




Quote:
Originally Posted by ukguy4672
I recently purchased a Sony Ericsson P910i. I have had it just over a week now and am very happy with it.

I decided to install some useful apps such as SMan, demo versions of Handy Safe and Tracker. I quite liked Tracker so thought I would purchase the full product. I registered my details using my IMEI number with SymbianWare. (as displayed on the back of my handset behind the battery)

I received an email today with my registration key and set about registering my version of Tracker. When I opened the registration window I noticed that the IMEI number displayed was different to the IMEI number that I had registered with.

Since the registration key is generated using the IMEI number, when I entered the registration key, I got a 'code error' message.

I double checked the IMEI number on my handset, the handset box and by dialling *#06#. The IMEI number was the same in all 3 cases.

The IMEI number in the sysinfo utility in SMan and the registration window in Tracker are the same BUT different to the above. I installed another demo app and again the IMEI number was the same as in SMan and Tracker but different to the IMEI displayed on my handset/box.

I am rather confused as to why this is. It was my understanding that the IMEI number is unique to any given handset. So how can there possibly be 2 different IMEI numbers associated with my handset??

Has anyone else noticed the same? Any help/feedback would be really helpful.

  #3  
Old 27-11-2004, 10:07 AM
jbsoft jbsoft is offline
Registered User
 
Join Date: Nov 2004
Posts: 2
jbsoft is on a distinguished road
I have the same problem and read on another site it could be cured by a format of the C: drive. This didn't work in my case and neither does a Hard Reset or upgrade of the firmware. But each time you do one of these things the 'software' IMEI changes so it is impossible for software writers to keep up-to-date with this problem.

I have emailed SE but they don't appear capable of replying.

I'm currently considering what to do (get a refund on what is obviously a faulty phone OS or find another smartphone).
Ads

  #4  
Old 27-11-2004, 08:18 PM
Idan_Aharoni Idan_Aharoni is offline
Registered User
 
Join Date: Nov 2004
Posts: 13
Idan_Aharoni is on a distinguished road
Wirelessly posted (SonyEricssonP900/R101 Profile/MIDP-2.0 Configuration/CLDC-1.0)

Have you tried re-burning the flash memory? there is a slim chance it might help!

  #5  
Old 28-11-2004, 05:24 AM
jbsoft jbsoft is offline
Registered User
 
Join Date: Nov 2004
Posts: 2
jbsoft is on a distinguished road
I've heard back from SE now and they say that authors need to use the Mobinfo API. The author of Projekt has tried this and it works perfectly. So there is an answer! The information is on the SE web site but is well hidden.

The problem is known about at SE but they have no other solution at the moment.
 

Bookmarks

Tags
imei

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can a mobile be remotely locked via imei bmandelj Nokia 7650 1 04-07-2004 07:09 AM
IMEI has changed slightly barflux Sony Ericsson P800, P900 and P910 5 07-08-2003 05:57 AM
WARNING: Firmware upgrade changes your IMEI jpsanders Sony Ericsson P800, P900 and P910 9 24-04-2003 06:04 PM
Dubious usage of IMEI bluephone Sony Ericsson P800, P900 and P910 4 10-03-2003 09:25 AM
Where do I find my IMEI code? TheSpecialBoy Nokia 9210 and 9290 5 04-03-2003 03:44 PM



All times are GMT. The time now is 10:26 AM.


vBulletin skins developed by: eXtremepixels
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright Notes || Contact Us || Privacy Policy