All About Symbian - Nokia (S60) and Sony Ericsson (UIQ) smartphones unwrapped

  #1  
Old 14-01-2007, 03:42 AM
i7iceguy i7iceguy is offline
Registered User
 
Join Date: Jan 2007
Posts: 2
i7iceguy is on a distinguished road
ActiveSync Errors

hello all, I just bought a m600i after replacing my 990i. I installed activesync and whenever I receive an email I get this error:

Application Closed
Application: Exchange ActiveSync
Reason Code: KERN-EXEC
Reason number: 3

Does anybody know how to fix this error?

  #2  
Old 16-01-2007, 12:03 AM
paddytb's Avatar
paddytb paddytb is offline
Registered User
 
Join Date: Aug 2006
Location: Saffron Walden
Posts: 27
paddytb is on a distinguished road
Have you updated the phone to Organizer R5A12 and ActiveSync to 2.010? My syncing is flawless.

  #3  
Old 16-01-2007, 12:58 AM
i7iceguy i7iceguy is offline
Registered User
 
Join Date: Jan 2007
Posts: 2
i7iceguy is on a distinguished road
Quote:
Originally Posted by paddytb View Post
Have you updated the phone to Organizer R5A12 and ActiveSync to 2.010? My syncing is flawless.
Unfortunately when I try to update my phone, it will not let me. It says I already have the latest updates.

My version is R4C01.

To fix this problem, I uninstalled and reinstalled activesync
Ads

  #4  
Old 18-01-2007, 12:11 AM
fatboy fatboy is offline
Registered User
 
Join Date: Jan 2007
Posts: 2
fatboy is on a distinguished road
active sync - doesnt work

I am having the same problems. tells me that the certificate could not be verified. when i say yes to proceed it fails. log reports error 0x7370D02.

can anyone help me - i've been trying to push email from exchage server to the m600i for days.

Dataviz - dont want to know

Vodafone - answer the phone, very helpful, all internet settings are fine.

SE - terrible - suggest that the problem is not theirs, actually anyone else but them - eventually directed me to MS website...!!!

MS website - OK for win mobile 5 devices - nothing to help M600i user

SE are really missing a fantastic market opportunity here. the M600i is a way better "blackberry" - why on earth dont they make it easy to push email?????

ignorance gone to seed...

now that my spleen is vented... please can anyone help me make this work??

thanks in advance!

  #5  
Old 18-01-2007, 12:32 AM
Rafe's Avatar
Rafe Rafe is offline
Founder / Chief
 
Join Date: Jul 2001
Location: Sussex
Posts: 6,084
Rafe is a glorious beacon of lightRafe is a glorious beacon of lightRafe is a glorious beacon of lightRafe is a glorious beacon of lightRafe is a glorious beacon of lightRafe is a glorious beacon of light
Have you tried a fresh install on the Active Sync. get the latest download from the SE site. That certainly helped me solves some reliability issues (not the same as yours but may be worth a try?)
__________________
Remember: The search command is your friend.
Feedback wanted: PM, email or post with your suggestions, complaints, feedback.

  #6  
Old 19-01-2007, 09:52 PM
fatboy fatboy is offline
Registered User
 
Join Date: Jan 2007
Posts: 2
fatboy is on a distinguished road
Talking A solution....finally!

After hours and hours of frustration, finally I got a solution to this problem.

Just to re-cap, the issue is to sync the M600i with exchange server. The error message that you get - identified in the first posting in this thread - identifies a problem with your exchange server settings.

If you set the verbose log on your phone, try to sync using the Active Sync programme, you get an error code 0x7370D02.

an explanation of this error code can be found at - sorry I cant post the web address - I am too young a forum member
(thanks trifin - from the startcom forum)

So here is what it says!

The sync error is a type 403 and this is the solution:-

This error can be caused by an incorrect setting in the Exchange Server. Please contact your IT staff to confirm the following Exchange Server settings:

A. First, contact your IT staff to confirm the Exchange server uses "Integrated Windows Login" (see Microsoft documentation: - sorry wont accept the url!!!!

B. Also, please confirm with your IT staff that your account is enabled for ActiveSync.

C. Next, contact your IT staff to confirm that device security settings on the server allow access to devices that do not fully support password settings. This option is available in:

Exchange System Manager > Global Settings > Mobile Services > Device Security

If this checkbox was unchecked, you will get a 403 error with RoadSync, although a Win Mobile device would still sync properly.

Important:
In the Device Security Settings, if the first option "Enforce password on device" is unchecked, the settings below it are not applicable and won't effect RoadSync. If the "Allow access to devices..." box is unchecked and then checked, it will take approximately 15 minutes for the system to update and for RoadSync to begin to sync properly.


I checked the box, waited 15 mins and BINGO!!!! it worked!!!!!

YIPEEEEEE!!!!!

One side effect is that the 133 emails that sync'd have now cost me a fortune on vodafones GB ripoff tariff!

I recommend you uncheck the "push email" box on your phone and chose "manual" - to save you some money!

I cant tell you how happy I am!

  #7  
Old 14-03-2007, 03:51 PM
jstbeca jstbeca is offline
Registered User
 
Join Date: Mar 2007
Posts: 3
jstbeca is on a distinguished road
Getting same error after a week of use

I have been getting the same error as above and 1 more.

Application Closed
Application Exchange ActiveSync
Reason USER
Reason number 42

Application Closed
Application !AgendaServer
Reason code KERN-EXEC
Reason number 3

The first time it happened I couldn't find anything on it, so I reflashed the phone and the issue when away. I assumed something had just gotten corrupted, but after a week of use it is popping up again. It still gets emails from the exchange server through the push, but then it crashes and I end up with a pile of the messages since ActiveSync just restarts itself. The strange thing is that both times the phone has worked without any issues for a week and then the issue is pops up. I don't know what changes. Any ideas? I'm not a fan of resetting my phone every 2 weeks.

  #8  
Old 14-03-2007, 08:51 PM
jstbeca jstbeca is offline
Registered User
 
Join Date: Mar 2007
Posts: 3
jstbeca is on a distinguished road
403

I followed fatboy's instructions and they actually created a 403 Forbidden error instead. My IT guy said it didn't make sense, since it tightens the security on the server instead of making it more open for the phone to get it.

Please, has anybody had and fixed this issue?

  #9  
Old 16-04-2007, 03:25 PM
jstbeca jstbeca is offline
Registered User
 
Join Date: Mar 2007
Posts: 3
jstbeca is on a distinguished road
Found one reason for crash

I found the reason for my crash and a work around, but it is not ideal. I finally figured out that my crash was due to it trying to sync the Calendar. My crash would occur after a few weeks of use, everytime, so it looks like some file is getting filled up and is failing to update and crashes. To fix, I went to activesync and reset the data in the calendar, resynced and then reset the phone to get the main screen to update again. I found that my main screen got frozen in the last state after it crashes started. So I will have to reset and reload my calendar data every couple of weeks for as long as I decide to put up with the phone. I hope this helps others.
 

Bookmarks

Tags
activesync, errors

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
errors with A925 roland_k_ Motorola A920, A925, A1000, Benq P30 and P31 and Arima U300 0 09-10-2005 09:27 AM
Nokia 6630 and ActiveSync NightCrow Nokia 6630, 6680, 6681 and 6682 2 05-08-2005 09:16 PM
Full Access to Exchange ActiveSync Over the Air for UIQ Ewan UIQ 0 06-07-2005 09:25 AM



All times are GMT. The time now is 04:34 AM.


vBulletin skins developed by: eXtremepixels
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright Notes || Contact Us || Privacy Policy