All About Symbian - Nokia (S60) and Sony Ericsson (UIQ) smartphones unwrapped

  #1  
Old 19-07-2005, 10:44 AM
GirishShetty
Guest
 
Posts: n/a
C++ Link error Issues

Hi All,

I am facing some problem with one of my DLL. When I am compliling it for ARMV5, I am getting some linker errors for multiple defination Linker Errors like:

Error: L6200E: Symbol __aeabi_memmove multiply defined (by rt_memmove.o and drtaeabi{000a0000}-149.o).
Error: L6200E: Symbol __aeabi_memcpy4 multiply defined (by rt_memcpy_w.o and drtaeabi{000a0000}-147.o).
Error: L6200E: Symbol __memmove_aligned multiply defined (by rt_memmove_w.o and drtrvct2_2{000a0000}-13.o).
Not enough information to list image symbols.
Finished: 1 information, 0 warning and 3 error messages.
make[1]: *** [..\..\..\..\EPOC32\RELEASE\ARMV5\UREL\STDCpp.dll] Error 1

As you can see, those .o's are not mine and I have commented all memmove, memcpy from my code. Still I am getting these errors.
Can some one help me in rectifying these Erros. That will be of great help.

Thanks a lot
Girish

  #2  
Old 19-07-2005, 11:40 AM
N/A's Avatar
N/A N/A is offline
Registered User
 
Join Date: Mar 2003
Posts: 7,948
N/A is on a distinguished road
What device are you targeting? Which SDK/compiler are you using? I think they (current SDKs/compilers) support ARMI, ARM4 or THUMB, only (until Symbian OS 9 & related tools).
Ads

  #3  
Old 19-07-2005, 01:03 PM
Girishshetty
Guest
 
Posts: n/a
C++ Link Error

Quote:
Originally Posted by N/A
What device are you targeting? Which SDK/compiler are you using? I think they (current SDKs/compilers) support ARMI, ARM4 or THUMB, only (until Symbian OS 9 & related tools).
Hi

I am using ARMV5, and my compiler is rvct_2.2_435

Girish

  #4  
Old 19-07-2005, 03:27 PM
N/A's Avatar
N/A N/A is offline
Registered User
 
Join Date: Mar 2003
Posts: 7,948
N/A is on a distinguished road
OK. Then you might want to ask ARM: http://www.arm.com/support/contacts.html
 

Bookmarks

Tags
error, issues, link

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Link Error when building with THUMB UREL target nguyendieuhuong S60 (Series 60) 1 18-08-2005 06:47 AM
Incredibly frustrating link error on static function joape382 S60 (Series 60) 2 07-01-2005 09:08 AM



All times are GMT. The time now is 10:52 AM.


vBulletin skins developed by: eXtremepixels
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright Notes || Contact Us || Privacy Policy