All About Symbian - Nokia (S60) and Sony Ericsson (UIQ) smartphones unwrapped

  #1  
Old 06-09-2007, 11:38 AM
timsalmon's Avatar
timsalmon timsalmon is offline
Super Moderator
 
Join Date: Mar 2006
Location: Chichester
Posts: 363
timsalmon is on a distinguished road
E90 & Belkin Router: Solution to 'No Gateway Reply'

Having fought with this well reported problem almost since day one, I thought I'd post the solution that has now worked for me. I have a Nokia E90 (and an E70) and Belkin ADSL Modem with Wireless-G Router (54). When I first got the E90 it 'saw' the (unsecured) network no problem, and connected. Some time after that (and maybe since I took the E90 to work and hooked it up no problem with the Linksys Router there - no security) it just continued to report 'no gateway reply' every time I tried to connect. I trawled the forums and followed what advice I could find, but didn't get anywhere. All this time, the E70 went straight on - no problem - all the settings in the two phones were the same, but the E90 just kept reporting the error. I tried hard-resetting the E90 (full 3+*+green+power) but still no joy. I tried this because some dipstick at Belkin support told me that I had screwed the phone by confusing it with the network at my workplace (?!?). Anyway, no joy.

So I started fiddling and after ages, made it work by going into the Belkin Setup, checking free IP addresses when clicking on LAN Setup/DHCP Client List (from left menu) and making a note of the ones which are already used - you need to use an unused one. In LAN Setup/LAN Settings you'll see the Subnet Mask - make a note. You'll also find here the 'default gateway' but it's just called IP Address - make a note. Then in Internet WAN/DNS you'll find the Primary DNS and Secondary DNS settings - make a note.

Turning to the phone, open settings/connection/Access Points then open up the 'Belkin54g' Access Point for editing... Connection name: Belkin54g, Data Bearer: Wireless LAN, WLAN network name: Belkin54g, Network status: Public, WLAN network mode: Infrastructure, WLAN security mode: Open network. Then Options/Advanced Settings/IPv4 settings - Phone IP Address: try an address that you identified earlier wasn't being used, Subnet mask: what you made a note of, Default gateway: you noted it. Highlight and select DNS address, then put in your primary and secondary DNS addresses as you noted earlier.

Now I've seen all this information elsewhere on the forums, but not specifically for the Belkin and I could have used this to help me. The stuff I read assumed a knowledge of matters networking, which I don't have. So I hope this helps someone else before Nokia decide to fix this problem which seems to be pretty widespread. I did try a NSU on the phone but it said it had the latest version, incidentally.

For the record, I turned on the WEP security after I'd got it all working and it worked OK, then the next morning it failed again, so I'm not sure what that's about. At the moment I have no security on. I know I should have and I'll play with that but - it's working!

Tim
Ads

  #2  
Old 06-09-2007, 02:23 PM
NickAnstee NickAnstee is offline
Registered User
 
Join Date: Jul 2007
Posts: 38
NickAnstee is on a distinguished road
Not sure, but I have never had any luck with either Belkin or Linksys routers, I now have the BT (British Telecom) wireless router and it works perfectly with my E90, E61, MacBook etc (so much so that I have actually forgotten that I have got a router and that it is hidden behind the TV!). The other problem I found with Belkin/Linksys is although the signal reported was good it was subject to interference from concrete walls etc.

  #3  
Old 08-09-2007, 12:56 PM
palmy palmy is offline
Registered User
 
Join Date: Aug 2007
Posts: 3
palmy is on a distinguished road
I've had this problem on E70 with Linksys and managed to overcome it. Hope this helps you:

1. Go to the wireless setting on your router.
2. You should find a setting on "channel", which should have options from 1-13 or 1-10.
3. Choose one channel that is somewhere in the middle range e.g. 5-8.
4. Save the setting.

You should be OK.

  #4  
Old 08-11-2007, 12:41 PM
Liquid_Li0n's Avatar
Liquid_Li0n Liquid_Li0n is offline
Registered User
 
Join Date: Jan 2006
Location: Belgium
Posts: 293
Liquid_Li0n is on a distinguished road
Unhappy

The information on this topic already helped me a bit further but it is still a long way

First of all, I don't have a Belkin or LinkSys router but a SMC ADSL Wifi modem router 54g WPA2
Next to that I have an E90 with latest firmware
A desktop on XP Pro SP2 and a laptop on Vista Home Premium
The first thing I don't understand is why the range is so bad, The Router is behind the TV and I'm sitting upstairs with Laptop/E90 and no or very worse connection...
On the E90 I did what you told me and choose an unused IP address
In my Case 192.168.2.5, Subnetmask is 255.255.255.0 and standard gateway (I think) is 192.168.2.1 ( the address to access the router in a browser)

What I notice is that it connects (you see the lock appearing on the ::), but now I get the "gateway errormessage", before those settings from this topic, I always got "Predefined WPA key not valid" (or something like that because my phone is in Dutch language) and could not connect.

Before this SMC router I had a Belkin with WEP and it worked flawlessly with my Nokia E61 and HP Ipaq hx4700, now that I bought the SMC with WPA/WPA2 I only got my E61 connected after a long search aswell, I copied the same settings from it to the E90 (before this topic settings) and it wasn't succesful...

I also tried a trick from S60tips.com to disable the power saver in the advanced options of the wifi:
Tools | Settings | Wireless LAN | Options | Advanced | warning message click yes | auto config off, radio off, power saver off.
This helps a bit or otherwise I think it does but maybe you already tried it. So tell me what your opinion is?

P.S.: I'm in Channel 5 on my router and Wireless Mode is Mixed (11b+11g) because it seems that when I choose for 11g only it seems not to work well anymore...
__________________
- Nokia N900 (v10.2010.19-1 | pr1.2 | RX-51) with 4gb micro-SD, lots of software!
- Nokia E90 (v210.34.75 | 12-04-2008 | RA-6) with 8gb micro-SD, lots of options & software!
- Nokia E50 (v07.36.0.0 | 07-09-2007 | RM-170) with 2gb micro-SD "premier" & lots of software!

My Nokia Phone history--> 6150 | 3210 | 6210 | 6600 & N-Gage | N70 & 9500 | E61 & N73 ME | E90 & E50 | N900

Last edited by Liquid_Li0n; 08-11-2007 at 12:45 PM.
 

Bookmarks

Tags
belkin, e90, gateway, reply, router, solution

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
N80 Wifi Web - No gateway reply figurt Nokia N80 7 23-02-2010 07:52 PM
Services: No Gateway Reply (on wireless network) sam0483 Nokia N80 14 27-06-2007 07:11 AM
No gateway reply (-25502) creamdust Nokia N80 0 31-08-2006 02:05 AM
e60 -> wlan: No gateway reply! automatedreason Nokia Eseries S60 3.0 phones (E50, E60, E62, E61, E61i, E70) 1 06-08-2006 05:58 PM
no gateway reply, any ideas ? carl.hill Nokia N91, N91 8GB and Nokia 3250 2 20-07-2006 11:13 PM



All times are GMT. The time now is 02:43 AM.


vBulletin skins developed by: eXtremepixels
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright Notes || Contact Us || Privacy Policy