All About Symbian - Nokia (S60) and Sony Ericsson (UIQ) smartphones unwrapped

Go Back   All About Symbian Forums > Symbian Based Devices > UIQ > Sony Ericsson P990

View Poll Results: Was the article useful?
Very Useful. Worked for me ! 6 50.00%
Useful 2 16.67%
Little Useful 1 8.33%
Not at all useful 3 25.00%
Voters: 12. This poll is closed

 
 
Thread Tools Display Modes

  #1  
Old 25-10-2007, 08:18 PM
bagaria's Avatar
bagaria bagaria is offline
Registered User
 
Join Date: Oct 2007
Posts: 18
bagaria is on a distinguished road
Exclamation Configuring Exchange ActiveSync on P990i

For all those folks who have not been able to configure Exchange ActiveSync on P990i provided by DataViz Corp.

I am posting this article on the Forum because i spent 3-4 days with the IT department of my company trying to figure out the issue but in vain. Sony Ericsson support sucks and was of no use. Finally i resolved it myself ! If this post helps you please acknowledge !!!

Pre-conditions:

1. Your companys mail server should be MS Exchange Server 2003 with SP2 Installed.

2. Mobile access should be enabled for your profile on server. By default when profile is created it is enabled.

3. You have OWA (Outlook Web Access) enabled without use of VPN.

For more details / troubleshooting on configuration of MS Exchange Server for mobile access please email me.


Setps:

1. Install Exchange ActiveSync on P990i. This SIS file comes bundled with the phone or you can download it from the Sony Ericsson or DataViz website.

2. Make sure you have a working GPRS / 3G connection configured on your P990i

3. You will now require the following information to configure the software. Open the software on the phone and enter the follwing.

Username : Your NT / Login ID and password which you use to login to your desktop in office.

Server: Your exchange server address. This is usually the address you use to o access OWA on IE. Remove the "https://" part from the address and type under the server address field.

Domain: You can leave this blank.

Use SSL Check this box (This is for the secure connection)

Hopefully if things are correct at the server end and you have entered the correct settings in the setup this should get you going....Please feel free to post if you have any issues.

Note:
Before syncronizing your phone make sure you backup the contacts. There are chances that synch. might result into duplicates for the first time and you may have to manually delete / modify them.

Cheers ! Happy messaging !!!

  #2  
Old 24-12-2007, 02:55 PM
manisad manisad is offline
Registered User
 
Join Date: Dec 2007
Posts: 2
manisad is on a distinguished road
Hi bagaria,

Its great. I have one query. It was working very well, when i first time install the softwarer. It worked for 1 month or so. One day i had to reset the master of my P990i. Now when i do it it constantly give me an error that please check your server name. I don't know why

  #3  
Old 24-12-2007, 03:10 PM
bagaria's Avatar
bagaria bagaria is offline
Registered User
 
Join Date: Oct 2007
Posts: 18
bagaria is on a distinguished road
Thumbs up

Quote:
Originally Posted by manisad View Post
Hi bagaria,

Its great. I have one query. It was working very well, when i first time install the softwarer. It worked for 1 month or so. One day i had to reset the master of my P990i. Now when i do it it constantly give me an error that please check your server name. I don't know why
hi !
I guess it might be probably because :

1. you re-installed a different version of software on the phone which is not compatible

2. You might have entered an incorrect username and password on the account setup.

3. Or you might have changed your office / NT ID password which expires after certain no. of says as per the admin. policy.

- If none of the above is true ....email me / post the exact error msg. you get.
- Also if you have push enabled on the account settings, try disabling it and synch manually and try.
Ads

  #4  
Old 27-12-2007, 09:48 AM
manisad manisad is offline
Registered User
 
Join Date: Dec 2007
Posts: 2
manisad is on a distinguished road
Hi,

I have installed the same version, which i downloaded from sonyericsson site. If you know anyother version please let me know.

i am enterring same user name and password, which i am using to access my email on pc

error: preparing to sync connecting to internet...linking to Exchange Server.... Connection estalished! Connecting to Exchange.... Server error: 403 Server Refused connection! Please try to sync again. if this error persists, contact your exchanger server admin.

How to enable push button in account setting i dont know. can you let me know

thanks

Quote:
Originally Posted by bagaria View Post
hi !
I guess it might be probably because :

1. you re-installed a different version of software on the phone which is not compatible

2. You might have entered an incorrect username and password on the account setup.

3. Or you might have changed your office / NT ID password which expires after certain no. of says as per the admin. policy.

- If none of the above is true ....email me / post the exact error msg. you get.
- Also if you have push enabled on the account settings, try disabling it and synch manually and try.

  #5  
Old 27-12-2007, 12:41 PM
bagaria's Avatar
bagaria bagaria is offline
Registered User
 
Join Date: Oct 2007
Posts: 18
bagaria is on a distinguished road
Thumbs up

Quote:
Originally Posted by manisad View Post
Hi,

I have installed the same version, which i downloaded from sonyericsson site. If you know anyother version please let me know.

i am enterring same user name and password, which i am using to access my email on pc

error: preparing to sync connecting to internet...linking to Exchange Server.... Connection estalished! Connecting to Exchange.... Server error: 403 Server Refused connection! Please try to sync again. if this error persists, contact your exchanger server admin.

How to enable push button in account setting i dont know. can you let me know

thanks

hmmmm....

403 error is kind of strange. See this link for further troublshooting steps...

http://support.dataviz.com/support.srch?docid=14010

Other error codes are explained in this link:

http://support.dataviz.com/support.s...13679&pid=2000


It might also be possible that your exchnage server admin. in office has disabled the mobile sync. on the server settings.

Follow this article for settings on the serverm you can fwd. it to you IT team and cross check.

http://www.msexchange.org/tutorials/...rver-2003.html

You can download the correct version from here...
http://www.dataviz.com/downloads

Last edited by bagaria; 27-12-2007 at 12:47 PM.

  #6  
Old 11-03-2008, 10:32 AM
jaipsharma jaipsharma is offline
Registered User
 
Join Date: Mar 2008
Posts: 1
jaipsharma is on a distinguished road
Smile Unable to configure Exchange Activesync P990i

Hi

I had tried to follow the same steps as you mentioned but unable to configure my activesync with P990i.

I'm getting error while sync. Please help...

Starting user-initiated sync.
-------------

Preparing to sync
Start synchronization...
2.013 (334)
10/03/2008 3:04:47 pm
Preparing to sync
Connecting to Internet...
Linking to Exchange server...
Connection established!
Please try to sync again! If this error persists, please make sure that the Server name is correct and that you are in a good coverage area

0x7370C07 (httpErrTransactionTimedOut)
Sync failed!
10/03/2008 3:06:49 pm
Last sync: Error - see log
ClearMessageEntriesL() error: 0x0
mtminstaller eror: 0x0
Starting user-initiated sync.
-------------

DActiveSyncEngine::CanPerformSync() - Priority : 0x1
DActiveSyncEngine::CanPerformSync() - Finished : 0x1
Preparing to sync
CanConnectToInternet() - Checking Connection.
IAP : Ad-Hoc Bluetooth PAN, Type : LANService, ID : 4
IAP : Airtel MMS, Type : OutgoingGPRS, ID : 6
IAP : Mobile Office, Type : OutgoingGPRS, ID : 7
IAP : Airtel Live, Type : OutgoingGPRS, ID : 8
SNAP : Internet, ID : 1
DSymbianV2InternetConnectEngine::SetupConnectionPr efs() - SNAP ID : 1
DSymbianV2InternetConnectEngine::RunL()
mCurrStage=0x1
statusCode=0x0
DSymbianV2InternetConnectEngine::RunL() - Network Status :0x1
Start synchronization...
2.013 (334)
10/03/2008 3:09:08 pm
Preparing to sync
DActiveSyncDataManager::PrepareForCalendarSync()
DActiveSyncDataManager::PrepareForContactsSync()
DActiveSyncDataManager::PrepareForEMailSync()
DSymbianMessageManager::HandleSessionEventL() - EMsvServerReady
DSymbianOutlookMessage::GetTempProcessingFolderId( ) - failed to do GetTempProcessingFolderIdL() with ERR: 0xFFFFFFFFFFFFFFFF
DSymbianMessageManager::CompleteMsvSessionInit() - Failed to prepare the TempProcessing folder with ERR: 0xFFFFFFFFFFFFFFFF
DActiveSyncEngine::RunTask() - Ready for StartSync
EstablishInternetTimeoutInternalL() - Time Out Sec : 2100
IAP used : 0x8
Bearer ID : 3
MODEM Bearer
LastSocketActivityTimeout : -1
LastSocketClosedTimeout : 2100
IAP used : 0x7
Bearer ID : 3
MODEM Bearer
LastSocketActivityTimeout : -1
LastSocketClosedTimeout : 2100
DSymbianV2InternetConnectEngine::Connect()
DSymbianV2InternetConnectEngine::SetupConnectionPr efs() - SNAP ID : 1
Connecting to Internet...
IConn - KStartingSelection: 0x0
DSymbianV2InternetConnectEngine::RunL()
mCurrStage=0x2
statusCode=0x0
DSymbianV2InternetConnectEngine::RunL() : KErrNone - Connection created succesfully.
DSymbianHTTPSession::InternetConnect_RecievedRespo nse() - Connected To Internet
DSymbianHTTPSession::MakeReady() - Removing Validation Filter
SetupProxyIfRequiredL() - Preparyng PROXY info.
SetupProxyIfRequiredL() - Turning Proxy OFF
Linking to Exchange server...
DActiveSyncEngine::PrepareOptionsCommand() : 0x2
DActiveSyncEngine::PrepareActiveSyncCommand() : 0x2
Initiating Submission of the HTTP Transaction (Symbian)
URL (Built) : https://mail.fadvos.com/Microsoft-Se...RoadSyncClient
DSymbianHTTPTransaction::SubmitSymbianTransaction( ) - SubmitL() successfull.
Gprs connection successful: 0x8
Connection established!
IConn - KFinishedSelection: 0x0
IConn - KLinkLayerOpen: 0x0
DSymbianHTTPSession::RunL() - Forcing connection to terminate!
DActiveSyncEngine::HTTP_ReportError() - 0x7370C07
Please try to sync again! If this error persists, please make sure that the Server name is correct and that you are in a good coverage area

0x7370C07 (httpErrTransactionTimedOut)
Sync failed!
10/03/2008 3:11:10 pm
Last sync: Error - see log
DStargateAppUi::ActiveSync_ReportError():0x7370C07
DSymbianHTTPSession - timed out
DActiveSyncEngine::CancelSyncInternal() - STARTED.
DSymbianHTTPTransaction::CloseSymbianTransaction() - Closing.
DSymbianHTTPSession:isconnectFromInternet()
DSymbianHTTPSession:isconnectFromInternet() - Closing HTTP Session
DSymbianV2InternetConnectEngine::CloseConnection()
DActiveSyncEngine::CancelSyncInternal() - AdjustPrefs.
CancelSyncInternal() - FINISHED.
DSymbianV2InternetConnectEngine::RunL()
mCurrStage=0x2
statusCode=0x0
DSymbianV2InternetConnectEngine::RunL() : KErrNone - closing connection.
DSymbianV2InternetConnectEngine::CloseConnectionIn ternal() : Disconnecting from the internet.
Disconnect Finished!

Could you help???

  #7  
Old 11-03-2008, 09:14 PM
bagaria's Avatar
bagaria bagaria is offline
Registered User
 
Join Date: Oct 2007
Posts: 18
bagaria is on a distinguished road
Quote:
Originally Posted by manisad View Post
Hi bagaria,

Its great. I have one query. It was working very well, when i first time install the softwarer. It worked for 1 month or so. One day i had to reset the master of my P990i. Now when i do it it constantly give me an error that please check your server name. I don't know why
Please check your account settings again. You might have changed your desktop password but forgotten to change it on your phone under account settings.

  #8  
Old 11-03-2008, 09:39 PM
bagaria's Avatar
bagaria bagaria is offline
Registered User
 
Join Date: Oct 2007
Posts: 18
bagaria is on a distinguished road
Quote:
Originally Posted by jaipsharma View Post
Hi

I had tried to follow the same steps as you mentioned but unable to configure my activesync with P990i.

I'm getting error while sync. Please help...

Starting user-initiated sync.
-------------

Preparing to sync
Start synchronization...
2.013 (334)
10/03/2008 3:04:47 pm
Preparing to sync
Connecting to Internet...
Linking to Exchange server...
Connection established!
Please try to sync again! If this error persists, please make sure that the Server name is correct and that you are in a good coverage area

0x7370C07 (httpErrTransactionTimedOut)
Sync failed!
10/03/2008 3:06:49 pm
Last sync: Error - see log
ClearMessageEntriesL() error: 0x0
mtminstaller eror: 0x0
Starting user-initiated sync.
-------------

DActiveSyncEngine::CanPerformSync() - Priority : 0x1
DActiveSyncEngine::CanPerformSync() - Finished : 0x1
Preparing to sync
CanConnectToInternet() - Checking Connection.
IAP : Ad-Hoc Bluetooth PAN, Type : LANService, ID : 4
IAP : Airtel MMS, Type : OutgoingGPRS, ID : 6
IAP : Mobile Office, Type : OutgoingGPRS, ID : 7
IAP : Airtel Live, Type : OutgoingGPRS, ID : 8
SNAP : Internet, ID : 1
DSymbianV2InternetConnectEngine::SetupConnectionPr efs() - SNAP ID : 1
DSymbianV2InternetConnectEngine::RunL()
mCurrStage=0x1
statusCode=0x0
DSymbianV2InternetConnectEngine::RunL() - Network Status :0x1
Start synchronization...
2.013 (334)
10/03/2008 3:09:08 pm
Preparing to sync
DActiveSyncDataManager::PrepareForCalendarSync()
DActiveSyncDataManager::PrepareForContactsSync()
DActiveSyncDataManager::PrepareForEMailSync()
DSymbianMessageManager::HandleSessionEventL() - EMsvServerReady
DSymbianOutlookMessage::GetTempProcessingFolderId( ) - failed to do GetTempProcessingFolderIdL() with ERR: 0xFFFFFFFFFFFFFFFF
DSymbianMessageManager::CompleteMsvSessionInit() - Failed to prepare the TempProcessing folder with ERR: 0xFFFFFFFFFFFFFFFF
DActiveSyncEngine::RunTask() - Ready for StartSync
EstablishInternetTimeoutInternalL() - Time Out Sec : 2100
IAP used : 0x8
Bearer ID : 3
MODEM Bearer
LastSocketActivityTimeout : -1
LastSocketClosedTimeout : 2100
IAP used : 0x7
Bearer ID : 3
MODEM Bearer
LastSocketActivityTimeout : -1
LastSocketClosedTimeout : 2100
DSymbianV2InternetConnectEngine::Connect()
DSymbianV2InternetConnectEngine::SetupConnectionPr efs() - SNAP ID : 1
Connecting to Internet...
IConn - KStartingSelection: 0x0
DSymbianV2InternetConnectEngine::RunL()
mCurrStage=0x2
statusCode=0x0
DSymbianV2InternetConnectEngine::RunL() : KErrNone - Connection created succesfully.
DSymbianHTTPSession::InternetConnect_RecievedRespo nse() - Connected To Internet
DSymbianHTTPSession::MakeReady() - Removing Validation Filter
SetupProxyIfRequiredL() - Preparyng PROXY info.
SetupProxyIfRequiredL() - Turning Proxy OFF
Linking to Exchange server...
DActiveSyncEngine::PrepareOptionsCommand() : 0x2
DActiveSyncEngine::PrepareActiveSyncCommand() : 0x2
Initiating Submission of the HTTP Transaction (Symbian)
URL (Built) : https://mail.fadvos.com/Microsoft-Se...RoadSyncClient
DSymbianHTTPTransaction::SubmitSymbianTransaction( ) - SubmitL() successfull.
Gprs connection successful: 0x8
Connection established!
IConn - KFinishedSelection: 0x0
IConn - KLinkLayerOpen: 0x0
DSymbianHTTPSession::RunL() - Forcing connection to terminate!
DActiveSyncEngine::HTTP_ReportError() - 0x7370C07
Please try to sync again! If this error persists, please make sure that the Server name is correct and that you are in a good coverage area

0x7370C07 (httpErrTransactionTimedOut)
Sync failed!
10/03/2008 3:11:10 pm
Last sync: Error - see log
DStargateAppUi::ActiveSync_ReportError():0x7370C07
DSymbianHTTPSession - timed out
DActiveSyncEngine::CancelSyncInternal() - STARTED.
DSymbianHTTPTransaction::CloseSymbianTransaction() - Closing.
DSymbianHTTPSession:isconnectFromInternet()
DSymbianHTTPSession:isconnectFromInternet() - Closing HTTP Session
DSymbianV2InternetConnectEngine::CloseConnection()
DActiveSyncEngine::CancelSyncInternal() - AdjustPrefs.
CancelSyncInternal() - FINISHED.
DSymbianV2InternetConnectEngine::RunL()
mCurrStage=0x2
statusCode=0x0
DSymbianV2InternetConnectEngine::RunL() : KErrNone - closing connection.
DSymbianV2InternetConnectEngine::CloseConnectionIn ternal() : Disconnecting from the internet.
Disconnect Finished!

Could you help???
- What are your server settings on Exchange Server ? Did you configure your account properly? Is OWA enabled for your id?
- Did you make sure that the pre-conditiones mentioned in the post above are met by the exchange server you are on?
 

Bookmarks

Tags
activesync, configuring, exchange, p990i

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ActiveSync with Exchange 2003 server SP2 kekke Sony Ericsson P990 4 25-10-2007 08:30 PM
M600i - forced inactivity lock with MS Exchange / ActiveSync paddytb Sony Ericsson M600i 8 19-12-2006 09:37 PM
P990i and Exchange Activesync - Where is it? Stash Sony Ericsson P990 2 19-09-2006 08:18 PM
Exchange ActiveSync software for Eseries devices now available Rafe Series 60 1 17-05-2006 03:54 PM
Full Access to Exchange ActiveSync Over the Air for UIQ Ewan UIQ 0 06-07-2005 09:25 AM



All times are GMT. The time now is 07:13 PM.


vBulletin skins developed by: eXtremepixels
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright Notes || Contact Us || Privacy Policy