View Single Post

  #8  
Old 04-09-2004, 11:52 PM
MemphisX's Avatar
MemphisX MemphisX is offline
Registered User
 
Join Date: Dec 2002
Location: Thessaloniki/Greece
Posts: 1,089
MemphisX is on a distinguished road
Quote:
Originally Posted by MemphisX
To my bad luck (or maybe good) After testing the first solution I've recommend it to you a similar problem apeared to me. after setting the city (time zone) as well as the time in world clock everything was going well untill the time I've turned the phone off and then on,. I had the strange thing of seeing the time being set to the GMT (which means -2 hours as I live at Greece Thessaloniki with a GMT+2). Even when I tried to put the clock +2 hours (in order to have GMT+4 and trick the world clock app), the time strangely was reseted to the GMT again (some kind of synchronisation with the network maybe?).

I can't really find a pure sollution. I'll further examine the problem and then post my findings, although I am 90% sure that the problem is behind the world clock app.

The problem has actually been solved but I can't find the source of it as it was actually solved after a random series of action...

1.I tried to delete the folder C:\System\Apps\Clock using a 3rd party file manager. This file is actually holding the setting for the world clock app. The problem was still there after the restart. And the reconfiguration.

2.Installed Psiloc's World Clock Pro. The problem transformed from actually -2h to +3h of the real time... I've tried many combinations with no luck. The program was removed (and with it every Psiloc app I had).

3. I tried to live with the problem as I was actually not restarting/turning off the phone many times till one day. I was going for a haircut while I was waiting I was browding some of my photos using resco viewer. The place I was didn't had good signal (I was barely seeing the Op logo). Then suddenly the phone hung and was not listening to my key presses. So I waited for the restart BUT after the restart the phone had the correct time.

After all the above , I solved the problem without actually knowing how. I tried many times either to restart the phone (using appman or the standard way by turning it off and then on) but the time was never again changed. I even tried to force the problem re-appear by doing the above mentioned things with no (bad?) luck.

I even tried to enable Auto time update which actually changed the time to +6 (and after the opening of the world clock app to +3). But after disabling it again the problem was vanished.

Then I remember that when the problem was first met it was when I changed my language from auto to english (through Setup->Settings->Phone->General->Phone Language) so I could write the solution I knew on the previous posts. I tried it again and to my surprise the time went to +3 after the restart. But again after changing the time to the correct and restarting the problem was vanished once more till the time I changed the language again to auto...

Somehow after doing the language change many times I found some problems. There were a few times that after changing the time from auto (which is the greek Language to me) to English after restarting the phone hung. I had to remove the battery and turn it on. I found out that the Language was not changed but on the menu The english lang. was selected as the chosen! But during the many changes I've also managed to have the problem re-appear but now instead of subtracting 2 hours it adds 3!!!

I was kinda confused. Next thing I've done was to enable auto time update. After the restart I'Ve noticed 2 things. firstly the time was +3 and a few secs later was +6(which was normal).

I've changed the time from the world Clock app and then turned off time update from settings. After that I made a restart. No change. Second restart the time changed to +3! Changed the language from greek to Auto. Then Turned on the auto time update again after correcting the time was not changed after the first restart. After the second it was again to +6...
Again changed the time to the correct (through the world Clock app) and then dissabled the auto time update.

Problem solved...

Although all the above are not an actual sollution, with some testing (maybe of the last few steps) you may cure your phone...
__________________
SX1, Symbian News and many more :



Not everyone is meant to make a difference.
But for me the choice to live an ordinary life is no longer an option.

If there was no GOD it would be neccessary to invent him.