View Single Post

  #13  
Old 05-11-2007, 05:12 PM
Sekra Sekra is offline
Registered User
 
Join Date: Oct 2007
Posts: 6
Sekra is on a distinguished road
About someone saying in a post here that WPA doesnt work its not true.
I got logged in at my school to the WLAN using WPA (WPA Enterprise). The only problem I had was that I had to login to a specific domain which there wasnt any setting but I was able to solve this with the help of our school helpdesk. Using username<at-symbol>domain (could not post the correct symbol (no <> naturally) since I dont have enough posts in these forums since it thinks its a email) I was able to login to the wlan and everything worked just fine then.

Getting the correct settings you need to be really careful. If your router has WPA-PSK you have to use WPA-Personal in your P1i. Using WPA-Enterprise is same as "just" WPA. From the page you set the SSID and no encryption/WEP/WPA-PSK/WPA you select next from the lower right corner menu (more? dont know since I use finnish language in the phone) Then there are all the TKIP/AES, PEAP/EAP-TLS/EAP-TTLS/...... and many other setting and after all those you have to set a username and password (when using WPA Enterprise). Be SURE you know ALL these settings from your router and set them to match in your phone and it will work.

Also someone said that the P1i can only connect if channel is set to 1. I've tried at home using channels 1-16 with WEP + TKIP encryption and got it working every time. Also the network at school which uses WPA + TKIP / WPA2 + AES encryption I've been able to connect at channels 2 and 6 (I cannot influence what channels the routers at school use).

In total I have 3 pages of setting I had to set in my P1i to get it to connect and the only way to save the settings is to select next in the last page (if you select the X it will discard any changes made).

Last edited by Sekra; 05-11-2007 at 05:27 PM. Reason: typo...