All About Symbian Forums

All About Symbian Forums (http://www.allaboutsymbian.com/forum/index.php)
-   Nokia 9210 and 9290 (http://www.allaboutsymbian.com/forum/forumdisplay.php?f=7)
-   -   Problem with Message Storage on MMC (http://www.allaboutsymbian.com/forum/showthread.php?t=1798)

seancsy 23-08-2002 04:31 PM

Problem with Message Storage on MMC
 
Hi, I wonder if anyone has the same problems I face.

Ever since I change my message storage to my MMC card (64MB), I occasionally get the following problems:

1. Sometimes when I received an SMS, I realise that the message storage has been changed back to "Communicator". I have to change the setting back to "Memory Card" again. This happens sparringly but it really annoys me. Since the just receibed message is in Communicator, when I want it to be in Memory Card. :cry:

2. Occasional when I open up the messaging app, all action buttons on the right hand side is greyed out. I cannot select any thing at all. I have to change the message storage from "Memory Card" to "Communicator" and back to "Memory Card" before it's normal again. :evil:

Can anyone offer any solution or suggestion? :D

upponalle 24-08-2002 11:17 AM

That doesn't sound like a normal problem :( Which version are you running on? I moved the message storage straight to my MMC card (and have been running now on 3 different versions 3.54, 3.62 and 4.13) and never had a problem.
Once the message storage was configured to MMC, it stayed there.
Sorry that I couldn't help you more...

sr666 24-08-2002 11:24 AM

I had the same problom when i receve a sms when i had my card out of the phone, the storage diverted back to the phone.

hope this helps.

upponalle 24-08-2002 11:31 AM

That is normal! It happened to me by accident after the last update when I forgot to change to the message storage back to MMC card right away. So there are now a couple of SMS on C:\ ... :)

Nosferatu 24-08-2002 11:33 AM

Re: Problem with Message Storage on MMC
 
Quote:

Originally Posted by seancsy
Hi, I wonder if anyone has the same problems I face.

Ever since I change my message storage to my MMC card (64MB), I occasionally get the following problems:

1. Sometimes when I received an SMS, I realise that the message storage has been changed back to "Communicator". I have to change the setting back to "Memory Card" again. This happens sparringly but it really annoys me. Since the just receibed message is in Communicator, when I want it to be in Memory Card. :cry:

:D Hi, Greetings from Malaysia...

i'm using version 4.13 and yeah sometimes that also happens to me... :(
PM me and maybe we could meet up???

upponalle 24-08-2002 11:38 AM

Sounds like some Malaysian problem... :D

Zuber 24-08-2002 12:47 PM

It happened to me a few times as well (when I had a 9210)

Not sure, but I think it is related in some way to if the Memory card is deactivated at all.

If for example, you open the hinge door, that deactivates the card. The messaging program switches the device to memory. Not sure if that always happens, or only when the program is activated exactly.

Anyway, I made a point of always removing the battery before opening the door to remove the MMC card, and the problem stopped occuring.

Try it out, I can't test it any more since I no longer have a 9210 :D

Zuber

seancsy 24-08-2002 05:10 PM

:o 1stly, I face the mentioned 2 problems using v3.62 and v4.13.

I have even tried deleting the mail directroy under system in the device. But when the storage is reset back to device, the directory and subtrees are automatically re-created again.

Seems like only malaysian users are facing these problems huh?!

I do suspect something: the memory card I am using (a EagleTec 64MB) is too slow. Whenever the system perform some sort of soft reset on the MMC, it's not able to respond in time, causing the system to reset the storage to device. Like I said, the problems occur only sparringly. However, I do not have another 64MB MMC to verify my suspicion.

Any clue?

02-09-2002 10:43 AM

Hey! I had same problem. I updated phone programs (4.13), I bought new 64 memory card, but didn't help. I went to the local servicing point here in Finland and I got help.
There is a grey plastic cover behind your phone, below the battery. It covers your mmc an sim card. It was twisted. There is a microswitch and it don't get contact if cover is broken. They changed it to the new one and after that my communicator has operated faultlessly.

I hope that helps you too

Biizei

Arc 02-09-2002 10:16 PM

I've found that when the machine reboots itself (on it's own, without me invoking it?? surely that doesn't happen? :roll: ), if I haven't entered the PIN code from the front of the phone, then I often get the greyed out buttons on the right hand side in the messaging app. To fix it, I have to turn it off and then on from the phone side.

Andrew

seancsy 30-09-2002 05:18 PM

Thanks for all your tips.

I have solved the problem permanently, after testing it for ant 4 weeks.

The problem seems to be the cover to the SIM & MMC cards is loose after some use. I did not change the cover to the SIM & MMC card. I just cut a very small piece of paper (~0.3mm thick) and glue it to the microswitch. This makes sure that the microswitch is depressed correctly when the cover is closed.

My storage never switch back to C: unless I want it to.

Guys, thanks for all your tips, especially Biizei's.

AAY 01-10-2002 01:17 PM

Quote:

Originally Posted by seancsy
Thanks for all your tips.

I have solved the problem permanently, after testing it for ant 4 weeks.

The problem seems to be the cover to the SIM & MMC cards is loose after some use. I did not change the cover to the SIM & MMC card. I just cut a very small piece of paper (~0.3mm thick) and glue it to the microswitch. This makes sure that the microswitch is depressed correctly when the cover is closed.

My storage never switch back to C: unless I want it to.

Guys, thanks for all your tips, especially Biizei's.

Ah yes, the wad-of-paper-over-the-switch solution rarely fails :D .

Who was your phone distributed by? Mine came from Multilink and after some gentle persuasion, they gave me a new cover for free (the original one I had had some damage on the hinge). Even if you can't get it free, it should be about RM15, I think.

01-10-2002 01:29 PM

Quote:

Originally Posted by seancsy
Thanks for all your tips.

I have solved the problem permanently, after testing it for ant 4 weeks.

The problem seems to be the cover to the SIM & MMC cards is loose after some use. I did not change the cover to the SIM & MMC card. I just cut a very small piece of paper (~0.3mm thick) and glue it to the microswitch. This makes sure that the microswitch is depressed correctly when the cover is closed.

My storage never switch back to C: unless I want it to.

Guys, thanks for all your tips, especially Biizei's.

Good to hear that it works now :)

Biizei

Coolmatter 01-10-2002 02:23 PM

New problem
 
I've read the posts for moving the messages from c: to d: but when I try that it just says Server is busy and I have to soft reset the 9210 and the storage is still on C:
Can anyone help me? I have 4.13 firmware

seancsy 02-10-2002 06:29 AM

This might not be recommended:

1. Start File Manager
2. Change settings so that you can see system folders.
3. Change to drive D: or MMC card.
4. Try to locate a "Mail" folder under the "System" folder. If there is a "Mail" folder alrdy, delete it & its tree. Make sure you are not deleting the 1 in drive C: or communicator.
5. Close File Manager & restart the unit.
6. Try the Move procedure as previously tried.

I never encounter your problem, but I will try the above if I do.


All times are GMT. The time now is 11:56 PM.

Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.