All About Symbian Forums

All About Symbian Forums (http://www.allaboutsymbian.com/forum/index.php)
-   Nokia Nseries S60 5.0 phones (Nokia N97 and Nokia N97 mini) (http://www.allaboutsymbian.com/forum/forumdisplay.php?f=109)
-   -   Help! My Nokia N97 mini got Security Module Error (http://www.allaboutsymbian.com/forum/showthread.php?t=90629)

ichwong 22-11-2009 06:43 AM

Help! My Nokia N97 mini got Security Module Error
 
I have bought the new phone for just a week and I have to hard reset it once.

Firstly, I see the out of memory error while starting the Web Browser.
I didn't have any other application running and thus I've no choice but to do the hard reset.

Recently, I see the same issue again and it seems the problem is due to the "Security Module" instead of actual out of memory. I notice that I don't see the WLAN when I had the security module error and thus why the phone fails to connect to Internet (Because something cause the Wireless LAN to start).

Now, I know that I need to power off and power on it again and the problem might temporary gone. However, this is not the perfect solution as it sometimes still fail and I have to restart the phone again.

Any other got any ideas?

:mad:

jApi NL 22-11-2009 09:14 AM

Security Module ?
 
What do you mean by Security Module ? Is it third party software , like virus protection ? Just de-install it !

:) Regards jApi NL

ichwong 22-11-2009 10:29 AM

Quote:

Originally Posted by jApi NL (Post 448351)
What do you mean by Security Module ? Is it third party software , like virus protection ? Just de-install it !

:) Regards jApi NL

It is not a third party software, it is part of the S60 OS.

jApi NL 22-11-2009 02:25 PM

Yes / No
 
Sorry , I was not really aware of this . I use nokia phones for several years , but never needed security modules . Now I checked my Phone in Security Settings and found the item . But : there are no SM's listed , so no SM's running ? Options give me two selections : 1) Help , 2) Exit .
Help tells me that I can change or in some cases delete SM's . Nothing about installing SM's .
My phone is running fine on 3G , WiFi . So I still think your SM is a third party software , either installed by your Provider or Company ? Anyway not part of the OS .

:) Regards jApi NL

dez_borders 03-12-2009 02:08 PM

Quote:

Originally Posted by ichwong (Post 448348)
I have bought the new phone for just a week and I have to hard reset it once.

Firstly, I see the out of memory error while starting the Web Browser.
I didn't have any other application running and thus I've no choice but to do the hard reset.

A few questions for you before I offer a diagnosis...

1. Is your handset network branded (if so, which network)?
2. What apps have you installed (including pre-installed apps by your network).
3. Which apps are installed in the phone memory?
4. How much RAM is free after a reboot? (Most N97 owners seem to have between 40 to 50MB RAM free after a reboot).

Hints:
You can get a full list of installed apps (and where they are installed) using Menu->Settings->Application Mgr->Installed Apps.
Apps installed in memory card or mass memory will show a small white icon to the right of the application name.
Apps installed to phone memory will not show the icon.
You can see how much RAM is free by a long MENU button press.

sashalr 20-12-2009 09:31 PM

my phone is also playing up!
 
hi i have the same problem with my phone i have had it just under a month and have had to hard reset it 3 times so far. although when i get the security module error i tend to get messages popping up saying to close other applications when i dont have any open. i now cant even hard reset the handset as that message pops up stopping me. i havnt installed any new applications since i got the phone. please help! i got it straight from the warehouse so i dont believe any different software was installed.

ichwong 28-02-2010 09:18 AM

Hi sashalr,

I'm sorry to hear about your problem!
I just wish to check if you still having the issue or not.

In my case, I've updated the N97 mini phone software to v11.045 but still having the same problem.

I also tried a lot of hard reset but the problem will eventually pop up. Here is my experience so far.

1) The error will happen less frequent after hard reset.

2) I always doubt it was some software compatibility issues although all the software I'm using works flawlessly at 5800XM.

3) At last, I do a hard reset in the following sequence
- Remove any memory cards
- Hard Reset the phone
- Setup the phone normally as you do at the 1st time.
- Format the "Mass Memory"
- Restore only the phone book and the appointments
- Install the new applications only to the phone memory.

4) You may also wish to avoid installing any applications to determine what is the problematic software having problems.

5) You may also wish to check if there are any software previously installed on the memory cards. I say that because in one of my test cases, I installed some widgets on the memory card. After doing the hard reset and insert the memory card backs, those widgets are remained and no longer need to be re-installed. But I observe another strange thing. The OVI Store Client that was automatically installed is no longer listed in the application listing. So, after that, I avoid installing software / widgets on the card.

After doing all the listed above on yesterday, I got 1 memory full error right after I restart the phone for 6 to 7 times. I tried it to see if my list of applications will crash it.

The applications I installed are:
- Handy Safe Pro
- RoadSync 5.001
- Hong Kong Apple Daily News
- Hong Kong Weather Widget
- iSilo for Symbian S60 5.0
- Time Zone Database Update
- OVI Map 3.0
- Meteor (Full Version)

ironass 28-02-2010 09:36 AM

The logical way to approach your problem would be to hard reset your phone and then add your app's, one-by-one, to see which one generates the error.

ajeet 28-02-2010 12:06 PM

Quote:

Originally Posted by ian-ross@beeb.n (Post 459086)
The logical way to approach your problem would be to hard reset your phone and then add your app's, one-by-one, to see which one generates the error.

I had the same problem with my N97(when it was with Ver 20 only). I did what Ian suggests but to no avail. The error will still happend some times.
When I updated to Ver 21, that problem has not recurred. Maybe there is some bug in the firmware for the N97 mini.


All times are GMT. The time now is 12:51 AM.

Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.