All About Symbian Forums

All About Symbian Forums (http://www.allaboutsymbian.com/forum/index.php)
-   Nokia Numbered S60 5.0 (Nokia 5800, Nokia 5230, Nokia 5530) (http://www.allaboutsymbian.com/forum/forumdisplay.php?f=105)
-   -   wlan wpa-enterprise problems (http://www.allaboutsymbian.com/forum/showthread.php?t=93425)

twtb 06-03-2010 09:53 PM

wlan wpa-enterprise problems
 
I want to connect to the wireless network on school but it will not work.

This is how we configure the connection in windows vista or 7. Without doing this we cannot connect to wifi.
We do import the following settings with

Quote:

netsh wlan add profile filename=".\Wireless-HowestWireless.xml" interface="Wireless Network Connection"
Wireless-HowestWireless.xml:
Quote:

<?xml version="1.0"?>
<WLANProfile xmlns="http://www.microsoft.com/networking/WLAN/profile/v1">
<name>HowestWireless</name>
<SSIDConfig>
<SSID>
<name>HowestWireless</name>
</SSID>
<nonBroadcast>false</nonBroadcast>
</SSIDConfig>
<connectionType>ESS</connectionType>
<connectionMode>auto</connectionMode>
<autoSwitch>true</autoSwitch>
<MSM>
<security>
<authEncryption>
<authentication>WPA</authentication>
<encryption>TKIP</encryption>
<useOneX>true</useOneX>
</authEncryption>
<OneX xmlns="http://www.microsoft.com/networking/OneX/v1">
<EAPConfig><EapHostConfig xmlns="http://www.microsoft.com/provisioning/EapHostConfig"><EapMethod><Type xmlns="http://www.microsoft.com/provisioning/EapCommon">25</Type><VendorId xmlns="http://www.microsoft.com/provisioning/EapCommon">0</VendorId><VendorType xmlns="http://www.microsoft.com/provisioning/EapCommon">0</VendorType><AuthorId xmlns="http://www.microsoft.com/provisioning/EapCommon">0</AuthorId></EapMethod><ConfigBlob>010000003E000000010000000100 00000100000015000000170000000000000000000100000017 0000001A00000001000000000000000000000000000000</ConfigBlob></EapHostConfig></EAPConfig>
</OneX>
</security>
</MSM>
</WLANProfile>
Then I can login with my username (jan.pol@howest.be) and password. (this is not my real email so please answer in this thread)
My notebook is not in a domain.

The certificate that is used by my school is not valid, so we need to deactivate "validate certificate" in windows, maybe that's the problem.

On my mobile phone I tried many different settings but it never worked.
Can somebody help me to find out the correct settings for this network? Thanks!

This is what I think must be correct, but it isn't:
Quote:

Connection name: HowestWireless
Data bearer: Wireless LAN
WLAN network name: HowestWireless
Network status: Public
WLAN network mode: Infrastructure
?WLAN security mode: WPA/WPA2 (do I need to choose 802.1x here?)
Homepage: None
Use access point: Automatically

*WLAN security settings*
WPA/WPA2: EAP
?WPA2 only mode: Off

*EAP plug-in settings*
Only EAP-PEAP checked

*EAP-PEAP settings* (I think the problem is here)
Personal certificate: Not defined
Authority certificate: Not defined
Username in use: User defined
Username: jan.pol
Realm in use: User defined
Realm: (empty)
TLS pricacy: On
Allow PEAPv0: No
Allow PEAPv1: No
Allow PEAPv2: Yes

*EAPs*
Only EAP-MSCHAPv2 is checked

*Cipher*
Everything checked

*EAP-MSCHAPv2 settings*
Username: jan.pol@howest.be
Prompt password: Yes *(it even don't asks for my password :s)
Password: (my password)
Can somebody please help me find out which settings are not correct?

twtb 09-03-2010 08:36 AM

anyone?


All times are GMT. The time now is 04:36 PM.

Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.