View Full Version : MMS not working after firmware upgrade (o2)


DJAd
19-11-2007, 11:14 AM
Hi guys,

A friend gave me his old N95 as my phone broke, it was on O2 and running an old V10 firmware, I had a read up and flashed with NSS and used a generic product code to grab the new firmware, it all went on fine and de-branded the handset, it's now running: V12.0.013.

I then went onto the O2 site to send my settings for MMS & WAP etc, and it wont work, it wont send or receive picture messages or any thing using the GPRS. Even if I use the "settings wizard" in the tools menu I get the settings but they don't work either!!

It's doing my head in now, any one have any ideas? I took to a phone shop and a guy said that O2 might not support the V12 firmware yet, is he talking crap?

Any help would be great.

3Shirts
19-11-2007, 11:50 AM
Hi guys,

A friend gave me his old N95 as my phone broke, it was on O2 and running an old V10 firmware, I had a read up and flashed with NSS and used a generic product code to grab the new firmware, it all went on fine and de-branded the handset, it's now running: V12.0.013.

I then went onto the O2 site to send my settings for MMS & WAP etc, and it wont work, it wont send or receive picture messages or any thing using the GPRS. Even if I use the "settings wizard" in the tools menu I get the settings but they don't work either!!

It's doing my head in now, any one have any ideas? I took to a phone shop and a guy said that O2 might not support the V12 firmware yet, is he talking crap?

Any help would be great.

Yes he is. Even if they don't have an O2 branded version of the V12 firmware (which I'm pretty sure they do) that has nothing to do with the connection settings which will work the same for any firmware version. The best thing is to call O2 and find out if there is a problem with your account or the local cell and if not, ask them to send you the connection settings. I often found with O2 that you get different settings from different places (the net, the wizard, the callcenter) but those are the most reliable

DJAd
19-11-2007, 12:09 PM
The best thing is to call O2 and find out if there is a problem with your account or the local cell and if not, ask them to send you the connection settings. I often found with O2 that you get different settings from different places (the net, the wizard, the callcenter) but those are the most reliable

I was thinking about this, the trouble is, the phone is a friends, he was meant to send it back as it broke (faulty speaker), but he didn't as they never asked for it. Since then they have sent him another, so he has given it to me. I just popped my O2 sim and it all worked, apart from said settings.

I'll go to my local O2 shop and see what they say. Also, the internal speaker is very very quiet, can this be changed? This is the original fault with the handset.