View Full Version : Nokia N95 Camera Problem


spinalonga
14-11-2007, 09:51 PM
I've had my N95b for 24 hours and I love it compared to N95. Screen much better, responsiveness, build quality.

BUT my camera has stopped working :-| I took around 20 pics so far, but now I just get a black screen when I try to open the camera. I can see the icons and everything but just black. If I swap the camera to the front one, it works but it seems that the main lens/camera is faulty. I have tried switching off/on, battery trick etc... but no luck. Has anyone experienced this?

kontraband
14-11-2007, 10:11 PM
nope... have you tried a soft/hard reset seeing as nothing else has worked?

spinalonga
14-11-2007, 10:27 PM
nope... have you tried a soft/hard reset seeing as nothing else has worked?

I just tried to Restore factory settings. Also formatted Mass storage. Restarted phone. I have remove battery etc....Same thing.

Any other tricks to try?

kontraband
14-11-2007, 10:34 PM
I just tried to Restore factory settings. Also formatted Mass storage. Restarted phone. I have remove battery etc....Same thing.

Any other tricks to try?

not really... have you checked your memory card... can you change the setting on the camera?

spinalonga
14-11-2007, 10:38 PM
nope... have you tried a soft/hard reset seeing as nothing else has worked?

not really... have you checked your memory card... can you change the setting on the camera?

There is no memory card on N95B, it has 8GB mass memory built in. I tried switching camera mode between phone/mass memory, no luck :frown:

rottie
14-11-2007, 10:46 PM
Are you not holding it covering the camera lens with your finger? :wink:

kontraband
14-11-2007, 10:46 PM
There is no memory card on N95B, it has 8GB mass memory built in. I tried switching camera mode between phone/mass memory, no luck :frown:


HAHAH yeah, sorry about that memory card bit.. :rolleyes: I knew that... just clutching at straws

spinalonga
14-11-2007, 10:49 PM
Are you not holding it covering the camera lens with your finger? :wink:

Yeah that a few time :tongue:

The weird thing is that I cannot snap at all. I can see all icons, can go to settings etc.... but the background is black and no snapping :con?

FogDogg
14-11-2007, 11:53 PM
Does the lens cover inside the camera open? I'm not talking about the traditional N95 lens cover that you open yourself, but on the 8GB version inside the glass theres a cover/flap that opens when you select the camera app.

spinalonga
15-11-2007, 12:05 AM
Are you not holding it covering the camera lens with your finger? :wink:

I never realised this. But I think that this could be it! I looked inside the lens and I cannot see the usual "curved" lens. I can only see a black shutter when the camera is turned on. See attached pic, is this correct?

Mithent
15-11-2007, 12:12 AM
Hard to see from the picture.. but when I start the camera on my N95-1, I can hear a click from the shutter opening if I listen closely. Do you get that?

spinalonga
15-11-2007, 12:16 AM
Hard to see from the picture.. but when I start the camera on my N95-1, I can hear a click from the shutter opening if I listen closely. Do you get that?

I put my ear very close and this is what I hear:

- When camera is off, there is a very faint "ticking" noise

- When camera is on, the faint "ticking" noise continues + there is a faint "buzzing" noise

But no shutter type sound when I switch on camera.

FogDogg
15-11-2007, 01:52 AM
Yeah you should be able to see something open when you hear the ticking noise. My N95 8GB ticks once when I press the camera button, and the cover thing opens. Maybe yours is stuck...

Because yeah, my N95 8GB is like that too before the cover opens... All I see is black and the menu buttons, and like half a seccond later the picture comes as the cover opens up.

davecozens
15-11-2007, 03:20 AM
Try hitting it against something (something padded) hard enough to jar it. Maybe it's only stuck a bit...

Failing that, drop it onto a carpeted floor or something...

If it's not working, it can't get any worse...

D

3Shirts
15-11-2007, 06:22 AM
Try hitting it against something (something padded) hard enough to jar it. Maybe it's only stuck a bit...

Failing that, drop it onto a carpeted floor or something...

If it's not working, it can't get any worse...

D

I think I'd try a service center before I start throwing my 600 phone on the floor :o

brittonc
15-11-2007, 10:03 AM
Can you touch the cover (like the manual one on the N95-1) or is it hidden behind a window? If it is you could try using a razor balde or something as thin to try prying then shutter open if it's just stuck.

FogDogg
15-11-2007, 10:59 AM
It's hidden behind a window. I guess if you really wanted to, you could take the whole back cover off.. But for this kind of money, just get the warrantee to take care of it.

spinalonga
15-11-2007, 11:28 AM
I went to Voda store and they swapped it for a new one. The problem was exactly what was mentioned earlier. Basically the internal shutter was jammed. Hopefully this one will work for longer than 24 hours :tongue:

qaazi
15-02-2009, 05:56 AM
Good News Guys !

I had same problem with my N95. Its just some hardware conflict between the camera nd accelerometer.
I just found the solution for this, just install "RescoBubbles" Games. Run the game once then close it, and now try the camera by sliding down the shutter.

IT WORKS !!!

Download the game here
h**p://rapidshare.com/files/198259531/RescoBubbles.sis