View Full Version : P990i not detected by mRouter


SJR
07-11-2006, 05:15 PM
My brand new Sony Ericsson P990i is not detected by the supplied mRouter software and as a result, I am unable to synchronise my phone with my PC.

The P990i is identified correctly by the PC and file transfer between the PC and the Phone Card works perfectly (i.e. I can open the Phone Card icon and drag/drop files to/From the Phone Card) - guess this means that the USB connection is working ok.

I have downloaded the latest version of PC Suite and the Developer Version of mRouter (which allows detailed logging of errors).

When attempting to connect to the P990 via Bluetooth, the following error appears in the connection log:
wsockhost initialized OK
Waiting...
Winsock Error (tcp): hr=0x8007271D

This same error code appears for both USB and Bluetooth connection attempts.

I have tried disabling the Anti-virus software, Spy Detection software and Windows Firewall, but this has no effect on the problem.

In Bluetooth mode the phone appears to connect, shows 'connected' for a split second but then immediately disconnects (each attempt causes the error message "Winsock Error (tcp): hr=0x8007271D" to appear in the log).

I have also tried uninstalling all Sony Ericsson and mRouter software then removing any artifacts relating to "Sony Ericsson" from the registry, rebooting then doing a clean install of all software, rebooting again then connecting the P990i.

For reference, my environment is as follows:
Operating System: Windows XP Pro SP2
PC Suite: v1.2.15
mRouter software: Developer Edition v3.1.042
Anti-Virus software: NOD32
Firewall: Windows XP Firewall
Spyware Detector: Webroot SpySweeper

This is very frustrating! Has anyone else experienced this problem and found a solution? :con?

Cheers,

Steve

P.S. I have previously used PC Suite and mRouter on this PC successfully for both the Sony Ericsson P800 and P900, but the version of the software for these phones has been fully uninstalled before loading any of the new software.
When I connect my old Sony Ericsson P900 via USB or Bluetooth, the new mRouter identifies and connects to the phone immediately so I guess mRouter is working ok - it must be the P990i...?

jah
12-11-2006, 04:44 PM
@SJR

found this tip at Esato that may help as the older version of PC Suite may not be fully uninstalled.

Advice from Esato member "Nitro Fan"

-----------------------------------------------------------------------------------------------------
check the following to make sure all the files have been removed from your PC.

1. On the PC, go to START > PROGRAMS or ALL PROGRAMS > ACCESSORIES > WINDOWS EXPLORER

2. Use the folder path below; Remove the content and the folders at the end of each path.

Note: Remove everything in the below catalogues and registry. Remember to be careful so that you do not remove other applications in the same folders/registry. Sometimes there can be both a Sony Ericsson and a Sony Ericsson 2 folder, this could mean that there is another application or an earlier installation of the PC software.

C:\\PROGRAM FILES\\SONY ERICSSON (e.g. Remove only Mobile, Mobile 4. folders)
C:\\PROGRAM FILES\\COMMON FILES\\TELECA SHARED (e.g. Remove the TELECA SHARED folder)
C:\\DOCUMENTS AND SETTINGS\\ALL USERS\\APPLICATION DATA\\SONY ERICSSON (e.g. remove all folders in SONY ERICSSON directory)
C:\\DOCUMENTS AND SETTINGS\\ALL USERS\\APPLICATION DATA\\TELECA (e.g. remove the TELECA folder)
C:\\DOCUMENTS AND SETTINGS\\\\APPLICATION DATA\\SONY ERICSSON (e.g. remove all folders in SONY ERICSSON directory, except for “backups” folder please rename this to “backups old”)
C:\\DOCUMENTS AND SETTINGS\\\\APPLICATION DATA\\TELECA (e.g. remove folder TELECA)
C:\\DOCUMENTS AND SETTINGS\\\\LOCAL SETTINGS\\APPLICATION DATA\\SONY ERICSSON\\MMSCOMPOSER (e.g. remove the MMS COMPOSER directory)
C:\\DOCUMENTS AND SETTINGS\\\\LOCAL SETTINGS\\APPLICATION DATA\\SONY ERICSSON\\SYNC STATION (e.g. remove folder SYNC STATION)

3. On the PC, go to START > RUN. This will open a dialog box with the text box.

4. In the text box enter 'regedit' and click OK. This will start the registry editor window.

5. Use the left side panel of the registry editor, navigate to the entries below by clicking the corresponding (+) symbols.

Then delete the folders at the end of each entry. Remember to be careful so that you do not remove other applications in the same folders or in the registry.


NOTE! With the next steps please be careful when entering the registry as this can have a serious impact on your system if the incorrect information is deleted. The customer must take full responsibility of there actions in the registry!

HKEY_CURRENT_USER\\SOFTWARE\\Sony Ericsson

HKEY_LOCAL_MACHINE\\SOFTWARE\\Ericsson

HKEY_LOCAL_MACHINE\\SOFTWARE\\Sony Ericsson

HKEY_LOCAL_MACHINE\\SOFTWARE\\Teleca

Please note, it is advised only proficient PC users alter registry values as incorrect edits of the registry can cause permanent damage to the PC operation.

6. Restart the PC

7. Download and install the latest Sony Ericsson PC suite from www.sonyericsson.com\\support

----------------------------------------------------------------------------------------------------

Also make sure when you fist connect your P990 and the new hardware is added this does not create other hardware conflicts (you can check via Control Panel>SYstem>Hardware>Devices on your PC)

Good luck

SJR
13-11-2006, 03:26 PM
Hi Jah,

Thanks for this!

... unfortunately, after performing all of the above steps, I am still unable to connect my P990i to my laptop :frown:

I followed all of the steps listed then rebooted, scoured the registry for any 'Ericsson' or 'Teleca' artifacts then rebooted again. I then reinstalled the PC Suite software (latest version from SE), rebooted again, then connected my P990i. All of the phone drivers were loaded successfully (Comm ports 9 and 14) and there were no conflicts.

mRouter momentarliy connects then immediately disconnects... (over and over again if you tell it to connect whenevr the phone is in range!). Same happens for USB connection - connects then drops immediately.

I have raised this with Sony Ericsson and have had some feedback from them.

I will post a solution here when (and if) I eventually get one.

Steve

jah
13-11-2006, 03:31 PM
@SJR

I have had a similar problem with an older PC using a AMD processor - my laptop with an Intel processor works fine. Interestingly the PC on which PC Suite does not work I have had a history of problems with faulty and corrupted USB drivers. When you speak to SE ask them about how to make 100% certain that the P990 USB drivers are deleted during an uninstall.

SJR
17-11-2006, 10:27 AM
Well, I have finally found the solution to my problem!!! :)

After trying all of the suggestions found on numerous forums, I finally stumbled upon the fix when following the advice of a friend relating to a totally different issue!

What was the problem?...
... IE7 (RC1)!!!!!

A friend asked me if I had installed the final release version of IE7 as it had fixed some comms problems that were found in the Release Candidate 1 version of the software. He suggested that I used add/remove programs to uninstall the IE7 RC1 version as apparently it does it a lot cleaner than the uninstall included with the final release of IE7.

So... I uninstalled IE7 RC1 using add/remove programs, installed IE7 and, blow me, PC Suite suddenly kicked into life and so did SEUS!!!

All of my P990i connection problems solved in one foul swoop!

So, if YOU have pulled out all your hair after trying everything possible, try reinstalling IE7 - it did the trick for me!

Thanks to everyone who offered advice.

Steve

PS... just the Bluetooth headset connection issue stopping me from enjoying my new phone now! (see seperate thread) ;)