View Full Version : Latest P800 sw version?


ginomi
01-12-2002, 11:40 PM
Dear P800 early buyer,

which is the latest sw version?
My vers:

Phone: CXC162002 R1A080
Organizer: CXC162001 R1B13
Bluetooth: CXC12529 R2C

I'm interested to know which is the newest version available in P800 shipped with the SonyEricsson bundle;
In my phone there is'nt the javaphone API...

Gino

michaelm
02-12-2002, 12:06 AM
My bundle arrived on friday.
Can you give me the code to get this software versions?


Michael

ginomi
02-12-2002, 09:27 AM
I don't have the P800 with me now, so later I will write more;
Go to Application menu (rightmost icon in the bar), select edit menu, "System Information" item.

tnx,

Gino

michaelm
02-12-2002, 05:56 PM
The same Versions in my P800..
I have some problems with Bluetooth Car FSE from Elsa (the same is produced by Peiker)!


Thanks for Information.

Michael

gunnar-p800
11-12-2002, 03:45 PM
Hello, support for the JavaPhone API is not included on P800.
If you find Sony Ericsson brochure- or web material that state otherwise, then please bring this to my attention.

Regards,

ginomi
11-12-2002, 04:14 PM
Hello, support for the JavaPhone API is not included on P800.
If you find Sony Ericsson brochure- or web material that state otherwise, then please bring this to my attention.

Regards,

At least in your "SonyEricsson P800 pJava Training Course":
http://www.ericsson.com/mobilityworld/sub/open/devices/p800/docs/P800_smartphone_training

Do you know if at least the JNI will be supported? Whit my fw version JNI was working in the phone, but a lot of C++ header was cutted in the latest UIQ sdk, so I'm in doubt if my apps will work in the final fw release!!!

Gino

gunnar-p800
12-12-2002, 01:06 AM
Hello, Yes, JNI is supported by PersonalJava on the P800. In the UIQ SDK you can only emulate a JNI solution in the UIQ emulator in case you have a Metrowerks Codewarrior for SymbianOS IDE edition installed along with the free UIQ SDK. I'll check if I detect any JNI library build limitations with the UIQ SDK.

I suggest opening the HTML file "Symbian/UIQ_70/Documentation/Packages/UIQ_70/uiq/uiqjava/QJavaDevGuide/jjni/index.html" in your installed UIQ SDK for more info and examples on JNI.

Regards,

ginomi
12-12-2002, 10:42 AM
The Infoprint example was working in the emulator and in the real phone. The trouble is using libs like etel and etelmm... I have built my pjava+native dll with the beta UIQ sdk, and in the phone I've this:

Program closed:
Program Java 4301e8 1
Reason code: KERN-EXEC
Reason number: 0

In my c++ code I've just "declared" a RTelServer session...

The same code, with the latest (final) version of UIQ sdk don't compile cause missing headers like etel.h!

I think the access to etel core functionality was disabled, a very trouble for my application; the big problem is the lack of documentation regarding wich C++ API is supported, wich no. Also for Javaphone was the same, I've found a "course" in SE site wich describe the use of this java API...

Do you know if there is other way to access the etel (etelmm) API?

tnx again for your replies,

Gino

13-12-2002, 09:43 PM
Dear P800 early buyer,

which is the latest sw version?
My vers:

Phone: CXC162002 R1A080
Organizer: CXC162001 R1B13
Bluetooth: CXC12529 R2C

I'm interested to know which is the newest version available in P800 shipped with the SonyEricsson bundle;
In my phone there is'nt the javaphone API...

Gino
My vers
Phone: CXC162002 R1B
Organizer: CXC162001 R1E02
Bluetooth: CXC12529 R2C

Stable, have no problems

15-06-2003, 09:25 AM
I did an update in a Sony Ericsson point, my version now :
phone : r2f
bluetooth : r5a
organiser : r2b03
cda : r2a01