View Full Version : Need SX1 user to test app


killermobile
17-12-2003, 12:36 AM
Hi Guys,

I need an SX1 tester or two to check compatiblity with AutoPilot, a Personal Call Management program. I exchange I will give you a free copy of the program. You can download the program @ www.killermobile.com (as well as a User Guide).

I look forward to the feedback.

Cheers!

Josh @
Killer Mobile
www.killermobile.com
AutoPilot - Personalized greetings for every caller. One for your Wife. One for your Girlfriend

OzBert
17-12-2003, 11:56 AM
It installs, it can be started.
But thats about it.

SplashScreen appears, then it quits with the error message: "AutoPilot: Feature not supported!".

FYI, OzBert

killermobile
17-12-2003, 10:41 PM
That sounds typical of a conflict with another program. Make sure all programs running in the background are turned off and reinstall the program. I believe that should fix the problem. There should be no reason why at the very least, the program won't load, however after that it is questionable =)

Cheers!

Josh @ Killer Mobile

killermobile
17-12-2003, 11:06 PM
Actually, now that I think of it, I believe that reaction was caused by the program trying to automatically detect the two ways IMEI numbers are presented for registration (which is ridiculous in the first place). In any case, I uploaded the old version where it does not do that. Would you mind trying again?

I greatly appreciate it!

Cheers!

Jsh @ Killer Mobile

OzBert
18-12-2003, 07:50 AM
Same old, same old.

I flashed the firmware yesterday, so I started with a clean slate so to speak.

Same error message.

It is the file behind "Download Demo", right?

Did you run it thru the SX1-SDK as well?
(www.siemens-mobile.com/developer)

"Sorry", OzBert

killermobile
18-12-2003, 08:29 AM
Hi OzBert,

I was under the impression that the sx1 simply uses the Series 60 SDK v1.2. The only SDK on their site is for Java development.

You downloaded the correct file, however I just updated it about 8 hours ago. I'll try to figure out what's going on.

Cheers!

Josh @ Killer Mobile

killermobile
20-12-2003, 07:49 PM
OK, I believe we've got this worked out. You can download an updated version for the SX1 here:

http://www.killermobile.com/AutoPilot_SX1.sis

Please let me know if everything is functioning correctly. You can download a full user guide at the killermobile.com site.

Cheers!

OzBert
20-12-2003, 09:40 PM
Josh,

This time I could run it.
I can access all the menu entries.

However (there always has to be one) it seems it does not do much.

I called the SX1 where I installed the app from another mobile, with CallID on (the number showed up in the SX1s internal records app), but on your apps "Log" didn't .

OzBert

killermobile
20-12-2003, 09:50 PM
Hi Ozbert,

Thanks for the test. First, AutoPilot won't place a number in the log, unless it finds a matching number in the "call list", and even then, it must match precisely. I've had a couple of users that have international number entries have problems when entering the number via the phone book option, however when they enter it manually exactly as it appears on the caller ID, then it works fine.

As not to turn this forum into a tech support for AutoPilot, would you mind emailing me at josh@ killermobile.com (remove the space).

Cheers!

Josh @
Killer Mobile